aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-12-11 00:23:15 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-12-11 00:23:15 +0000
commit18934abe0453cc08ac04cae9287f3a862a3d4481 (patch)
treef412ff0fc088a00d60872b0827df3b6b0c84f19a /Mk/bsd.port.mk
parent049486f9e89367e0a11feaea81d32538fbe8de45 (diff)
downloadports-18934abe0453cc08ac04cae9287f3a862a3d4481.tar.gz
ports-18934abe0453cc08ac04cae9287f3a862a3d4481.zip
bsd.port.mk: add LEGAL_TEXT and LEGAL_PACKAGE variable
The license system did not a method to give 'positive' permissions or other 'LEGAL' information without affecting the resulting package in some way (RESTRICTED, NO_PACKAGE, NO_CDROM, etc.). Provide a generic mechanism to provide this. Further, provide a special variable "LEGAL" which can be used to capture any of NO_PACKAGE, NO_CDROM, RESTRICTED, LEGAL_TEXT in reverse priority order. PR: ports/178096 Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=336130
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 15564d77184c..00f989cee6c7 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -169,6 +169,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# but distfiles can be put on ftp sites and CDROMs.
# FORBIDDEN - Package build should not be attempted because of
# security vulnerabilities.
+# LEGAL_TEXT - Port has legal issues (e.g., special permission to distribute, lacks a license).
+# LEGAL_PACKAGE - Port has no legal issues but defines NO_PACKAGE
# IGNORE - Package build should be skipped entirely (e.g.
# because of serious unfixable problems in the build,
# because it cannot be manually fetched, etc). Error
@@ -3164,6 +3166,17 @@ IGNORE= is marked as broken on ${ARCH}: ${BROKEN_${ARCH}}
IGNORE= is forbidden: ${FORBIDDEN}
.endif
+# Define the text to be output to LEGAL
+.if defined(LEGAL_TEXT)
+LEGAL= ${LEGAL_TEXT}
+.elif defined(RESTRICTED)
+LEGAL= ${RESTRICTED}
+.elif defined(NO_CDROM)
+LEGAL= ${NO_CDROM}
+.elif defined(NO_PACKAGE) && ! defined(LEGAL_PACKAGE)
+LEGAL= ${NO_PACKAGE}
+.endif
+
.if (defined(MANUAL_PACKAGE_BUILD) && defined(PACKAGE_BUILDING))
IGNORE= has to be built manually: ${MANUAL_PACKAGE_BUILD}
clean: