aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-09-03 20:47:01 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-09-03 20:47:01 +0000
commit2650f95f80f1ba6fa7b84b5018c87bf9ec34196f (patch)
tree99c269d6ec5c609902084b2e6e0822f948356dda /Mk/bsd.port.mk
parenteeed9bb04dc3659cce75e1df42eadd8735831f04 (diff)
downloadports-2650f95f80f1ba6fa7b84b5018c87bf9ec34196f.tar.gz
ports-2650f95f80f1ba6fa7b84b5018c87bf9ec34196f.zip
- Add hast to USERS_BLACKLIST [1].
- Add USE_READLINE knob [2]. - Fix typo [3]. PR: ports/157128 [1] PR: ports/162995 [2] PR: ports/165125 [3] Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> [1], fjoe [2], "Conrad J. Sabatier" <conrads@cox.net> [3]
Notes
Notes: svn path=/head/; revision=303619
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk19
1 files changed, 17 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9bb03da1eea0..3223752ecd74 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -383,6 +383,12 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_SDL - If set, this port uses the sdl libraries.
# See bsd.sdl.mk for more information.
##
+# USE_READLINE - If set, this port uses libreadline.
+# Legal values are: yes, base, port
+# yes, base: use base system libreadline on FreeBSD 9 or earlier,
+# use ports/devel/readline on FreeBSD 10.0+
+# port: always use ports/devel/readline
+##
# USE_OPENAL - If set, this port relies on the OpenAL package.
# Legal values are: al, soft, si, alut.
# If set to an unknown value, the port is marked broken.
@@ -1259,7 +1265,7 @@ GID_OFFSET?= 0
# predefined accounts from src/etc/master.passwd
# alpha numeric sort order
-USERS_BLACKLIST= _dhcp _pflogd bin bind daemon games kmem mailnull man news nobody operator pop proxy root smmsp sshd toor tty uucp www
+USERS_BLACKLIST= _dhcp _pflogd bin bind daemon games hast kmem mailnull man news nobody operator pop proxy root smmsp sshd toor tty uucp www
LDCONFIG_DIR= libdata/ldconfig
LDCONFIG32_DIR= libdata/ldconfig32
@@ -1697,6 +1703,15 @@ MAKE_ENV+= ${b}="${${b}}"
.include "${PORTSDIR}/Mk/bsd.ldap.mk"
.endif
+.if defined(USE_READLINE)
+.if ${USE_READLINE} == "port" || ${OSVERSION} > 1000000
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lreadline
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.endif
+.endif
+
.if defined(USE_OPENAL)
_OPENAL_ALL= al si soft alut
_OPENAL_LIBS= si soft
@@ -4454,7 +4469,7 @@ pretty-print-www-site:
if [ -n "$${www_site}" ]; then \
${ECHO_MSG} -n " and/or visit the "; \
${ECHO_MSG} -n "<a href=\"$${www_site}\">web site</a>"; \
- ${ECHO_MSG} " for futher informations"; \
+ ${ECHO_MSG} " for further information"; \
fi
.endif