aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-01-22 16:35:23 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-01-22 16:35:23 +0000
commit2816b55780dedb51f4276fd0373975b6f80041b7 (patch)
treec3416ccad5fa3a08a254c968a7c1baf034bf43f5 /Mk/bsd.port.mk
parent859fd6a16c5e7be3faded9dc21ac47fa6a5316ee (diff)
downloadports-2816b55780dedb51f4276fd0373975b6f80041b7.tar.gz
ports-2816b55780dedb51f4276fd0373975b6f80041b7.zip
add new stage-qa target: gemfiledeps
This checks whether rubygem based ports have all of their dependencies in Gemfile(s) satisfied by what's currently installed. Sample output: ====> Running Q/A tests (stage-qa) Warning: Dependencies defined in /usr/ports/www/gitlab/work/stage/usr/local/www/gitlab/Gemfile are not satisfied These ports could (!) be broken at runtime. Be aware: some projects defines multiple Gemfiles and not all are used at runtime. For example www/gitlab has two Gemfiles, but only one is used for testing and warnings about it can be ignored. Approved by: portmgr (mat), lifanov Differential Revision: https://reviews.freebsd.org/D11865
Notes
Notes: svn path=/head/; revision=459673
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 3db728b11168..c16ebed77c7a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1616,7 +1616,8 @@ QA_ENV+= STAGEDIR=${STAGEDIR} \
PKGBASE=${PKGBASE} \
PORTNAME=${PORTNAME} \
NO_ARCH=${NO_ARCH} \
- "NO_ARCH_IGNORE=${NO_ARCH_IGNORE}"
+ "NO_ARCH_IGNORE=${NO_ARCH_IGNORE}" \
+ USE_RUBY=${USE_RUBY}
.if !empty(USES:Mssl)
QA_ENV+= USESSSL=yes
.endif