aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-18 09:19:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-18 09:19:42 +0000
commit2c5c4bf9e31966627c749a81c0bfbd69d38fb22c (patch)
tree225d693e0f07400ea8d19fd04b887a0d4bcc72e0 /Mk/bsd.port.mk
parent7344937efc010b3233407519a954293da55fb3e8 (diff)
downloadports-2c5c4bf9e31966627c749a81c0bfbd69d38fb22c.tar.gz
ports-2c5c4bf9e31966627c749a81c0bfbd69d38fb22c.zip
Currently, when bsd.port.mk outputs a message addressed to a user, it would
typically pipe it through ${FMT} 75 79 command to ensure that if it gets overly long, it would be wrapped nicely. Do the same when outputting IGNORE message which often gets very long. While here, add missing section number in sed(1) references in comments. Differential Revision: D4116 Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=401851
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1ed4f64b6ed9..15bfb31aa717 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -565,7 +565,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR} "! -name *\.bak"
#
# Installs all directories and files from ${WRKSRC}/doc
-# to ${DOCSDIR} except sed backup files.
+# to ${DOCSDIR} except sed(1) backup files.
#
# MANPREFIX - The directory prefix for ${MAN<sect>} and ${MLINKS}.
# Default: ${PREFIX}
@@ -898,7 +898,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# PLIST_SUB - List of "variable=value" pair for substitution in ${PLIST}
# Default: see below
#
-# SUB_FILES - Files that should be passed through sed and redirected to
+# SUB_FILES - Files that should be passed through sed(1) and redirected to
# ${WRKDIR}.
# - For each file specified in SUB_FILES, there must be a
# corresponding file in ${FILESDIR} whose suffix is ".in". For
@@ -2815,7 +2815,7 @@ clean:
.if defined(IGNORE_SILENT)
IGNORECMD= ${DO_NADA}
.else
-IGNORECMD= ${ECHO_MSG} "===> ${PKGNAME} "${IGNORE:Q}.;exit 1
+IGNORECMD= ${ECHO_MSG} "===> ${PKGNAME} "${IGNORE:Q}. | ${FMT} 75 79 ; exit 1
.endif
_TARGETS= check-sanity fetch checksum extract patch configure all build \