aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2018-01-04 19:07:42 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2018-01-04 19:07:42 +0000
commit2c91ba6c3c54804e8320befef89ea832bc25a129 (patch)
tree558db387601b5c6ba19335da8ed1d147ce393c12 /Mk/bsd.port.mk
parent120ee164f6818d50b105d5faa914e0532c089e65 (diff)
downloadports-2c91ba6c3c54804e8320befef89ea832bc25a129.tar.gz
ports-2c91ba6c3c54804e8320befef89ea832bc25a129.zip
Fix package-depends-list for FLAVORS.
Reported by: dinoex Approved by: portmgr (implicit) MFH: 2018Q1
Notes
Notes: svn path=/head/; revision=458041
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 91455caf8e9b..6ad80888a9da 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4212,6 +4212,12 @@ PACKAGE-DEPENDS-LIST?= \
fi; \
checked="${PARENT_CHECKED}"; \
for dir in ${_LIB_RUN_DEPENDS:C,[^:]*:([^:]*):?.*,\1,}; do \
+ case $${dir} in \
+ *@*) \
+ flavor=$${dir\#*@}; \
+ dir=$${dir%@*}; \
+ ;; \
+ esac; \
case "$$dir" in \
/*) ;; \
*) dir=${PORTSDIR}/$$dir ;; \
@@ -4221,7 +4227,7 @@ PACKAGE-DEPENDS-LIST?= \
case $$checked in \
$$dir|$$dir\ *|*\ $$dir|*\ $$dir\ *) continue;; \
esac; \
- childout=$$(cd $$dir; ${MAKE} CHILD_DEPENDS=yes PARENT_CHECKED="$$checked" package-depends-list); \
+ childout=$$(cd $$dir; FLAVOR=$${flavor} ${MAKE} CHILD_DEPENDS=yes PARENT_CHECKED="$$checked" package-depends-list); \
set -- $$childout; \
childdir=""; \
while [ $$\# != 0 ]; do \