aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-03 19:03:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-03 19:03:58 +0000
commit37dea055cce10bd75617108cd98978cfb3240983 (patch)
tree4c931e7cd98d4cfe3ff1e4b107fab9e66c0dd135 /Mk/bsd.port.mk
parentf7ce5833897cf1987dec55e6e8f791a4572d2c0e (diff)
downloadports-37dea055cce10bd75617108cd98978cfb3240983.tar.gz
ports-37dea055cce10bd75617108cd98978cfb3240983.zip
Separate precious __softMAKEFLAGS from .MAKEFLAGS to fix certain build
problems with the new make(1) .MAKEFLAGS handling. To disable __softMAKEFLAGS caching, set NOPRECIOUSSOFTMAKEVARS (note: this is done by default if the new make(1) is being used). To disable .MAKEFLAGS caching, set NOPRECIOUSMAKEVARS (same as before). PR: standards/57295 Submitted by: harti Tested on: pointyhat
Notes
Notes: svn path=/head/; revision=115354
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ac136c17ea7b..a5146818808e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -803,6 +803,12 @@ check-makefile::
_PREMKINCLUDED= yes
+.if defined(MAKE_VERSION)
+.if ${MAKE_VERSION} >= 5200408030 || ${MAKE_VERSION} >= 4200408030 && ${MAKE_VERSION} < 5000000000
+NOPRECIOUSSOFTMAKEVARS= yes
+.endif
+.endif
+
AWK?= /usr/bin/awk
BASENAME?= /usr/bin/basename
BRANDELF?= /usr/bin/brandelf
@@ -4752,12 +4758,15 @@ depend:
tags:
.endif
-.if !defined(NOPRECIOUSMAKEVARS)
+.if !defined(NOPRECIOUSSOFTMAKEVARS)
.for softvar in CKSUMFILES _MLINKS
.if defined(${softvar})
__softMAKEFLAGS+= '${softvar}+=${${softvar}:S/'/'\''/g}'
.endif
.endfor
+.endif
+
+.if !defined(NOPRECIOUSMAKEVARS)
# These won't change, so we can pass them through the environment
.MAKEFLAGS: \
ARCH="${ARCH:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \