aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-23 17:52:38 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-23 17:52:38 +0000
commit3a69880c810ed7f09365998b77af706bb2fe3d02 (patch)
tree95b0402e6ded028ec23363e6360d4b7d5cbe32a3 /Mk/bsd.port.mk
parentcb162ca9bd01dea85f5387956ce38fc899ad6228 (diff)
downloadports-3a69880c810ed7f09365998b77af706bb2fe3d02.tar.gz
ports-3a69880c810ed7f09365998b77af706bb2fe3d02.zip
Remove checks for ia64, this is not a supported architecture.
PR: 237104 Approved by: portmgr
Notes
Notes: svn path=/head/; revision=499773
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 507185b1139e..1865943978a0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1797,9 +1797,9 @@ MAKE_ENV+= SHELL=${MAKE_SHELL} NO_LINT=YES
PATCH_DEPENDS+= ${LOCALBASE}/bin/unzip:archivers/unzip
.endif
-# Check the compatibility layer for amd64/ia64
+# Check the compatibility layer for amd64
-.if ${ARCH} == "amd64" || ${ARCH} =="ia64"
+.if ${ARCH} == "amd64"
.if exists(/usr/lib32)
HAVE_COMPAT_IA32_LIBS?= YES
.endif
@@ -1813,7 +1813,7 @@ HAVE_COMPAT_IA32_KERN!= if ${SYSCTL} -n compat.ia32.maxvmem >/dev/null 2>&1; the
_EXPORTED_VARS+= HAVE_COMPAT_IA32_KERN
.if defined(IA32_BINARY_PORT) && ${ARCH} != "i386"
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+.if ${ARCH} == "amd64"
.if !defined(HAVE_COMPAT_IA32_KERN)
IGNORE= requires a kernel with compiled-in IA32 compatibility
.elif !defined(HAVE_COMPAT_IA32_LIBS)