aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-05 20:15:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-05 20:15:48 +0000
commit3ac6602ab125db6c408b3de2e4435682ec75605f (patch)
treeb00717e4db857f593e77d1c5e05df4d91498212c /Mk/bsd.port.mk
parent43e5ca0c6a78f4d12fac64362e52b91a73e1a5b4 (diff)
downloadports-3ac6602ab125db6c408b3de2e4435682ec75605f.tar.gz
ports-3ac6602ab125db6c408b3de2e4435682ec75605f.zip
Move PKGORIGIN definition a bit later so that PKGCATEGORY defined in Makefile.local or Makefile.inc works again
Reported by: dinoex Tested by: dinoex
Notes
Notes: svn path=/head/; revision=322355
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bb4cc800d4b7..d9e6c9f711e6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1212,13 +1212,6 @@ WITH_PKGNG?= yes
# Only define tools here (for transition period with between pkg tools)
.include "${PORTSDIR}/Mk/bsd.commands.mk"
-.for _CATEGORY in ${CATEGORIES}
-PKGCATEGORY?= ${_CATEGORY}
-.endfor
-_PORTDIRNAME= ${.CURDIR:T}
-PORTDIRNAME?= ${_PORTDIRNAME}
-PKGORIGIN?= ${PKGCATEGORY}/${PORTDIRNAME}
-
MASTERDIR?= ${.CURDIR}
.if ${MASTERDIR} != ${.CURDIR}
@@ -1258,6 +1251,13 @@ USE_SUBMAKE= yes
USE_SUBMAKE= yes
.endif
+.for _CATEGORY in ${CATEGORIES}
+PKGCATEGORY?= ${_CATEGORY}
+.endfor
+_PORTDIRNAME= ${.CURDIR:T}
+PORTDIRNAME?= ${_PORTDIRNAME}
+PKGORIGIN?= ${PKGCATEGORY}/${PORTDIRNAME}
+
# where 'make config' records user configuration options
PORT_DBDIR?= /var/db/ports