aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-09-30 13:13:21 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-09-30 13:13:21 +0000
commit4810da6c37cf3550eb6d93de28ff228ca4a72bf3 (patch)
tree6e9669eb5f175411604c2c7879ded00de3e7b788 /Mk/bsd.port.mk
parente28bc67fc0a5ad8235a1e17cec996e865a8ae256 (diff)
downloadports-4810da6c37cf3550eb6d93de28ff228ca4a72bf3.tar.gz
ports-4810da6c37cf3550eb6d93de28ff228ca4a72bf3.zip
bsd.port.mk: clarify intended usage of REINPLACE_ARGS
This is a follow-up to mat clearing out invalid usage in r550694 -- the intention is only for the -i flag to be specified, and the framework can and does rely on this at times. Discussed with: mat Approved by: portmgr (mat)
Notes
Notes: svn path=/head/; revision=550700
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9c61b8c3bc3f..1b23d3f3a8e3 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2018,7 +2018,9 @@ CONFIGURE_ENV+= LANG=${USE_LOCALE} LC_ALL=${USE_LOCALE}
MAKE_ENV+= LANG=${USE_LOCALE} LC_ALL=${USE_LOCALE}
.endif
-# Macro for doing in-place file editing using regexps
+# Macro for doing in-place file editing using regexps. REINPLACE_ARGS may only
+# be used to set or override the -i argument. Any other use is considered
+# invalid.
REINPLACE_ARGS?= -i.bak
.if defined(DEVELOPER)
REINPLACE_CMD?= ${SETENV} WRKSRC=${WRKSRC} REWARNFILE=${REWARNFILE} ${SCRIPTSDIR}/sed_checked.sh