aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-08-25 13:53:02 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-08-25 13:53:02 +0000
commit4a6637715e126524d4ea3d761129c3a3422de172 (patch)
tree8fd9489aef3c770c3129fb4484368e4ed49182b1 /Mk/bsd.port.mk
parentebb79839d4b790fc2c1f6bca962c49212156ccbe (diff)
downloadports-4a6637715e126524d4ea3d761129c3a3422de172.tar.gz
ports-4a6637715e126524d4ea3d761129c3a3422de172.zip
Add a new flag: USE_IMAKE
This will cause the configure pass to do an `xmkmf' if set. Submitted by: jkh
Notes
Notes: svn path=/head/; revision=37
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ebe719b9e2c8..3d7f9fda5259 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.15 1994/08/22 13:25:33 jkh Exp $
+# $Id: bsd.port.mk,v 1.16 1994/08/24 14:49:33 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -184,6 +184,9 @@ ${CONFIGURE_COOKIE}:
.if defined(HAS_CONFIGURE)
@(cd ${WRKSRC}; ./configure ${CONFIGURE_ARGS})
.endif
+.if defined(USE_IMAKE)
+ @(cd ${WRKSRC}; xmkmf)
+.endif
@if [ -f ${SCRIPTDIR}/post-configure ]; then \
sh ${SCRIPTDIR}/post-configure ${PORTSDIR} ${.CURDIR} ${WRKSRC}; \
fi