aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-11-03 19:14:08 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-11-03 19:14:08 +0000
commit4cf1355420c12b6e53a22cec23cc3c39dca1f76b (patch)
tree3e634637ce05cf3ef09192f07b89edfa996c9053 /Mk/bsd.port.mk
parentc909193a30662ef7584c6a5447787006c6c0b94d (diff)
downloadports-4cf1355420c12b6e53a22cec23cc3c39dca1f76b.tar.gz
ports-4cf1355420c12b6e53a22cec23cc3c39dca1f76b.zip
Add reinstall target for Poul-H. This lets you install again from
the same build, ignoring the INSTALL_COOKIE.
Notes
Notes: svn path=/head/; revision=314
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ead078fa9641..a84d2d5ae9d2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.61 1994/11/01 18:09:22 jkh Exp $
+# $Id: bsd.port.mk,v 1.62 1994/11/01 21:04:27 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -75,6 +75,8 @@
# what's available.
# build - Actually compile the sources.
# install - Install the results of a build.
+# reinstall - Install the results of a build, ignoring "already installed"
+# flag.
# package - Create a package from a build.
#
# Default sequence for "all" is: fetch extract configure build
@@ -225,6 +227,13 @@ install:
# More standard targets start here.
+.if !target(reinstall)
+reinstall: pre-reinstall install
+
+pre-reinstall:
+ @rm -f ${INSTALL_COOKIE}
+.endif
+
.if !target(pre-install)
pre-install:
@${DO_NADA}
@@ -412,7 +421,8 @@ pre-clean:
.if !target(clean)
clean: pre-clean
@echo "===> Cleaning for ${DISTNAME}"
- @rm -f ${EXTRACT_COOKIE} ${CONFIGURE_COOKIE} ${INSTALL_COOKIE}
+ @rm -f ${EXTRACT_COOKIE} ${CONFIGURE_COOKIE} ${INSTALL_COOKIE} \
+ ${BUILD_COOKIE}
@rm -rf ${WRKDIR}
.endif