aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-06-06 10:56:34 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-06-06 10:56:34 +0000
commit5727f324eb8838a3a5fba00b3328260f45ccd76c (patch)
tree29e97716de0bc853d6aa05d5a83986c5c72484db /Mk/bsd.port.mk
parent9fe6ec35b86fbabaab4ddb4b6a6ce5128f010df4 (diff)
downloadports-5727f324eb8838a3a5fba00b3328260f45ccd76c.tar.gz
ports-5727f324eb8838a3a5fba00b3328260f45ccd76c.zip
Renamed the default package repository ".../packages/.packages" to
".../packages/All". The "all" category that was automatically added for every package is gone. Note that bsd.port.mk requires category names to start with lowercase names, otherwise it may get confused. Reviewed by: jkh By the way, here is a small script to convert your local package hierarchy. Run it in bash, as /bin/sh not only will bark at the $(.) command substitution but will also botch the [a-z]*/*.tgz expansion (long-standing and annoying bug, reported before). cd /usr/ports/packages mv .packages All for i in [a-z]*/*.tgz; do j=$(basename $i) /bin/rm $i ln -s ../All/$j $i done
Notes
Notes: svn path=/head/; revision=1824
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a840cdd2a768..ef9df00c5ed8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.163 1995/05/16 10:31:25 asami Exp $
+# $Id: bsd.port.mk,v 1.164 1995/05/29 13:46:38 asami Exp $
#
# Please view me with 4 column tabs!
@@ -305,10 +305,11 @@ PKGNAME?= ${DISTNAME}
# Documentation
MAINTAINER?= ports@FreeBSD.ORG
CATEGORIES?= orphans
-CATEGORIES+= all
KEYWORDS+= ${CATEGORIES}
-PKGREPOSITORYSUBDIR?= .packages
+# Note this has to start with a capital letter (or more accurately, it
+# shouldn't match "[a-z]*"), see the target "delete-package-links" below.
+PKGREPOSITORYSUBDIR?= All
PKGREPOSITORY?= ${PACKAGES}/${PKGREPOSITORYSUBDIR}
.if exists(${PACKAGES})
PKGFILE?= ${PKGREPOSITORY}/${PKGNAME}${PKG_SUFX}
@@ -975,7 +976,7 @@ package-links:
.if !target(delete-package-links)
delete-package-links:
- @rm -f ${PACKAGES}/*/${PKGNAME}${PKG_SUFX};
+ @rm -f ${PACKAGES}/[a-z]*/${PKGNAME}${PKG_SUFX};
.endif
.if !target(delete-package)