aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-21 07:34:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-21 07:34:50 +0000
commit58df3eebfbf665c42732ac556c094d39f5e1d1ff (patch)
tree156971a0ec4864410c29648995624f0c1a3ca904 /Mk/bsd.port.mk
parenta22457dbf7f9a66828c71c47e44de5aae95cd0a6 (diff)
downloadports-58df3eebfbf665c42732ac556c094d39f5e1d1ff.tar.gz
ports-58df3eebfbf665c42732ac556c094d39f5e1d1ff.zip
- Ports that use alternative targets to depend on others, for example:
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/foo/bar:target fail when built in jails that restrict network access during !fetch phase. This commit address this problem. Tested by: bmany exp-runs, drewery, bapt, crees PR: 169850 Submitted by: crees@
Notes
Notes: svn path=/head/; revision=314820
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index b0af8bf49fad..2fa3c44700ee 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4301,7 +4301,7 @@ _PKG_DEP= check-sanity
_PKG_SEQ= pkg-depends
_FETCH_DEP= pkg
_FETCH_SEQ= fetch-depends pre-fetch pre-fetch-script \
- do-fetch post-fetch post-fetch-script
+ do-fetch fetch-specials post-fetch post-fetch-script
_EXTRACT_DEP= fetch
_EXTRACT_SEQ= check-build-conflicts extract-message checksum extract-depends \
pre-extract pre-extract-script do-extract \
@@ -5167,6 +5167,7 @@ lib-depends:
_UNIFIED_DEPENDS=${PKG_DEPENDS} ${EXTRACT_DEPENDS} ${PATCH_DEPENDS} ${FETCH_DEPENDS} ${BUILD_DEPENDS} ${LIB_DEPENDS} ${RUN_DEPENDS}
_DEPEND_DIRS= ${_UNIFIED_DEPENDS:C,^[^:]*:([^:]*).*$,\1,}
+_DEPEND_SPECIALS= ${_UNIFIED_DEPENDS:M*\:*\:*:C,^[^:]*:([^:]*):.*$,\1,}
all-depends-list:
@${ALL-DEPENDS-LIST}
@@ -5302,6 +5303,14 @@ deinstall-depends:
done
.endif
+.if !target(fetch-specials)
+fetch-specials:
+ @${ECHO_MSG} "===> Fetching all distfiles required by ${PKGNAME} for building"
+ @for dir in ${_DEPEND_SPECIALS}; do \
+ (cd $$dir; ${MAKE} fetch); \
+ done
+.endif
+
.if !target(fetch-recursive)
fetch-recursive:
@${ECHO_MSG} "===> Fetching all distfiles for ${PKGNAME} and dependencies"