aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-09-29 17:01:41 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-09-29 17:01:41 +0000
commit5a4c543c2b0f538631aea8379ce384d5defee89d (patch)
tree108a55d148b3bc801facab0fb03b8666659c1136 /Mk/bsd.port.mk
parent7231ff2710fcc89472994d2e2d235e74e9c8704c (diff)
downloadports-5a4c543c2b0f538631aea8379ce384d5defee89d.tar.gz
ports-5a4c543c2b0f538631aea8379ce384d5defee89d.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 992e296f5496..79fd53ec8d3a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -358,7 +358,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# MAKE_ENV are extended with a DISPLAY variable.
#
# USE_GL - A list of Mesa or GL related dependencies needed by the port.
-# Supported components are: glut, glu, glw, and gl.
+# Supported components are: egl, glesv2, glut, glu, glw, and gl.
# If set to "yes", this is equivalent to "glu". Note that
# glew and glut depend on glu, glw and glu depend on gl.
##
@@ -1892,13 +1892,15 @@ MAKE_ENV+= DISPLAY="localhost:1001"
PKG_IGNORE_DEPENDS?= 'this_port_does_not_exist'
-_GL_gl_LIB_DEPENDS= GL.1:${PORTSDIR}/graphics/libGL
+_GL_glesv2_LIB_DEPENDS= libGLESv2.so:${PORTSDIR}/grahpics/libglesv2
+_GL_egl_LIB_DEPENDS= libEGL.so:${PORTSDIR}/graphics/libEGL
+_GL_gl_LIB_DEPENDS= libGL.so:${PORTSDIR}/graphics/libGL
_GL_gl_USE_XORG= glproto dri2proto
-_GL_glew_LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew
-_GL_glu_LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU
+_GL_glew_LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew
+_GL_glu_LIB_DEPENDS= libGLU.so:${PORTSDIR}/graphics/libGLU
_GL_glu_USE_XORG= glproto dri2proto
-_GL_glw_LIB_DEPENDS= GLw.1:${PORTSDIR}/graphics/libGLw
-_GL_glut_LIB_DEPENDS= glut.12:${PORTSDIR}/graphics/freeglut
+_GL_glw_LIB_DEPENDS= libGLw.so:${PORTSDIR}/graphics/libGLw
+_GL_glut_LIB_DEPENDS= libglut.so:${PORTSDIR}/graphics/freeglut
.if defined(USE_GL)
. if ${USE_GL:L} == "yes"