aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-03-16 13:10:01 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-03-16 13:10:01 +0000
commit69cef69d3008a6fc58a3db12913cc590821ecdf5 (patch)
treee9d5fb9039019affb0c15681b6c9ce438ecbd6ce /Mk/bsd.port.mk
parentd2c3fd757670f7864b0a2ef76ec9a065f15faf87 (diff)
downloadports-69cef69d3008a6fc58a3db12913cc590821ecdf5.tar.gz
ports-69cef69d3008a6fc58a3db12913cc590821ecdf5.zip
COPYTREE_SHARE should also be using _SHAREMODE and not SHAREMODE.
SHAREMODE defaults to 444, and gives us endless grief because one cannot modify a file that is not writable. So use _SHAREMODE that is 644, so that we can avoid all those CHMOD +w in so many Makefiles. Exp-run: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D7623
Notes
Notes: svn path=/head/; revision=436276
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 07bada101163..27b9adc9adc8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2075,7 +2075,7 @@ _SHAREMODE?= 0644
# A few aliases for *-install targets
INSTALL_PROGRAM= ${INSTALL} ${COPY} ${STRIP} -m ${BINMODE}
INSTALL_KLD= ${INSTALL} ${COPY} -m ${BINMODE}
-INSTALL_LIB= ${INSTALL} ${COPY} ${STRIP} -m ${SHAREMODE}
+INSTALL_LIB= ${INSTALL} ${COPY} ${STRIP} -m ${_SHAREMODE}
INSTALL_SCRIPT= ${INSTALL} ${COPY} -m ${BINMODE}
INSTALL_DATA= ${INSTALL} ${COPY} -m ${_SHAREMODE}
INSTALL_MAN= ${INSTALL} ${COPY} -m ${MANMODE}
@@ -2097,7 +2097,7 @@ COPYTREE_BIN= ${SH} -c '(${FIND} -Ed $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null 2>&
-o -type f -exec ${SH} -c '\''cd '\''$$1'\'' && chmod ${BINMODE} "$$@"'\'' -- . {} + \)' --
COPYTREE_SHARE= ${SH} -c '(${FIND} -Ed $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null 2>&1) && \
${FIND} -Ed $$0 $$2 \( -type d -exec ${SH} -c '\''cd '\''$$1'\'' && chmod 755 "$$@"'\'' -- . {} + \
- -o -type f -exec ${SH} -c '\''cd '\''$$1'\'' && chmod ${SHAREMODE} "$$@"'\'' -- . {} + \)' --
+ -o -type f -exec ${SH} -c '\''cd '\''$$1'\'' && chmod ${_SHAREMODE} "$$@"'\'' -- . {} + \)' --
# The user can override the NO_PACKAGE by specifying this from
# the make command line