aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
commit6d324c1f70c9ee4ebd41f6a689ac379f8d47927b (patch)
tree7c63a95968ed9b4eb610fca1b72ff17c7d9581c2 /Mk/bsd.port.mk
parent2da0cd8de2b6a439333303b69967925ed04914ad (diff)
downloadports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.tar.gz
ports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.zip
- Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile so
bsd.default-versions.mk can rely on ARCH being defined. - In bsd.port.mk move inclusion of bsd.default-versions.mk from the pre-makefile section to the options section so the variables can be used earlier. Also put the bit of code sitting between the options section and the pre-makefile section into the options section. - Remove last few cases where ports set WITH_OPENSSL_PORT. This variable is handled in bsd.default-versions.mk and some ports were setting it after including bsd.port.options.mk. After FreeBSD 9 EoL all but a few ports, and then only when setting non-default options, work without setting that variable. PR: 215996 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=433456
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 51faba6d8d22..fd958063a0ba 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1266,8 +1266,6 @@ GROUPS_BLACKLIST= _dhcp _pflogd _ypldap audit authpf bin bind daemon dialer ftp
LDCONFIG_DIR= libdata/ldconfig
LDCONFIG32_DIR= libdata/ldconfig32
-.endif
-
# At least KDE needs TMPDIR for the package building,
# so we're setting it to the known default value.
.if defined(PACKAGE_BUILDING)
@@ -1280,8 +1278,12 @@ WITH_DEBUG= yes
.endif
.endif
+.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
.include "${PORTSDIR}/Mk/bsd.options.mk"
+.endif
+# End of options section.
+
# Start of pre-makefile section.
.if !defined(AFTERPORTMK) && !defined(INOPTIONSMK)
@@ -1291,8 +1293,6 @@ WITH_DEBUG= yes
_PREMKINCLUDED= yes
-.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
-
.if defined(PORTVERSION)
.if ${PORTVERSION:M*[-_,]*}x != x
IGNORE= PORTVERSION ${PORTVERSION} may not contain '-' '_' or ','