aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-06 12:53:57 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-06 12:53:57 +0000
commit71aec7fcbdbe61e2bd2102c3faf90d7b6741c81b (patch)
treed1333b278517a8c62d339075eeec0734cd4c3f83 /Mk/bsd.port.mk
parent10c420eb5763dfe575be141f3479c88aa47f5ef2 (diff)
downloadports-71aec7fcbdbe61e2bd2102c3faf90d7b6741c81b.tar.gz
ports-71aec7fcbdbe61e2bd2102c3faf90d7b6741c81b.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d9e6c9f711e6..8b4fa0f16c68 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2178,7 +2178,7 @@ _MAKE_JOBS= #
MAKE_JOBS_NUMBER?= `${SYSCTL} -n kern.smp.cpus`
_MAKE_JOBS?= -j${MAKE_JOBS_NUMBER}
.if defined(FORCE_MAKE_JOBS) && !defined(MAKE_JOBS_SAFE)
-BUILD_FAIL_MESSAGE+= "You have chosen to use multiple make jobs (parallelization) for all ports. This port was not tested for this setting. Please remove FORCE_MAKE_JOBS and retry the build before reporting the failure to the maintainer."
+BUILD_FAIL_MESSAGE+= You have chosen to use multiple make jobs (parallelization) for all ports. This port was not tested for this setting. Please remove FORCE_MAKE_JOBS and retry the build before reporting the failure to the maintainer.
.endif
.endif
.endif
@@ -3711,7 +3711,7 @@ do-build:
@(cd ${BUILD_WRKSRC}; if ! ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}; then \
if [ -n "${BUILD_FAIL_MESSAGE}" ] ; then \
${ECHO_MSG} "===> Compilation failed unexpectedly."; \
- (${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
+ (${ECHO_CMD} "${BUILD_FAIL_MESSAGE}") | ${FMT} 75 79 ; \
fi; \
${FALSE}; \
fi)