aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-08-22 10:46:38 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-08-22 10:46:38 +0000
commit72d8a92acaf54f56f099deec45d475426c7094b4 (patch)
tree55ea23f5095f6e41f9eaa6d4a4c344ef4f4ffc63 /Mk/bsd.port.mk
parentd0451777b8d1288001be78d1c453a02cf8a4ba30 (diff)
downloadports-72d8a92acaf54f56f099deec45d475426c7094b4.tar.gz
ports-72d8a92acaf54f56f099deec45d475426c7094b4.zip
I had to bite the bullet: There's now a port.subdir.mk that does the right
thing with recursive build, configure, bundle or extract targets. Reviewed by: Submitted by:
Notes
Notes: svn path=/head/; revision=18
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5933bc1cec1d..336a818869d1 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.7 1994/08/21 17:42:24 jkh Exp $
+# $Id: bsd.port.mk,v 1.8 1994/08/21 18:26:10 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -171,6 +171,10 @@ clean:
@rm -rf ${WRKDIR}
.endif
-.if !target(cleandir)
-cleandir: clean
+# Depend is generally meaningless for arbitrary ports, but if someone wants
+# one they can override this. This is just to catch people who've gotten into
+# the habit of typing `make depend all install' as a matter of course.
+#
+.if !target(depend)
+depend:
.endif