aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-07-21 22:29:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-07-21 22:29:22 +0000
commit7336164f4912e81b6d20fc99305dbca3957b1cc0 (patch)
treee5592006c4bd4c3fec5754c407713575b5a5193b /Mk/bsd.port.mk
parentcd44a8ba7fa73965fa44d20e48a63adfc0a37102 (diff)
downloadports-7336164f4912e81b6d20fc99305dbca3957b1cc0.tar.gz
ports-7336164f4912e81b6d20fc99305dbca3957b1cc0.zip
- Separate OpenLDAP related code into bsd.ldap.mk
- Change default OpenLDAP version to 2.4 - Remove OpenLDAP 2.2 support, the port has been gone for some time now - Add -DDEPRECATED to CFLAGS for all OpenLDAP using ports PR: ports/123602, ports/124115, ports/125605 Submitted by: delphij, Jens Rehsack <rehsack@web.de>, Yuri Pankov <yuri.pankov@gmail.com> - Remove USE_GTK, it's no longer used PR: ports/123528 Submitted by: mezz - Use PATCH_WRKSRC instead of WRKSRC in do-patch target PR: ports/124169 Submitted by: Max Brazhnikov <makc@issp.ac.ru> - Remove USE_XPM, it's been replaced by USE_XORG+=xpm PR: ports/124506 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua> - Minor fixups for bsd.port.mk PR: ports/122675 Submitted by: linimon - Remove stale comment about USE_GETOPT_LONG PR: ports/124521 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua> - Correct comment about default fetch arguments PR: ports/125334 Submitted by: Gary Palmer <freebsd-gnats@in-addr.com>
Notes
Notes: svn path=/head/; revision=217264
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk52
1 files changed, 14 insertions, 38 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index f8f2c716c5bb..ed54092c6013 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -312,9 +312,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# GMAKE - Set to path of GNU make if not in $PATH.
# Default: gmake
##
-# USE_GETOPT_LONG
-# - If set, this port uses getopt_long. May be obsolete.
-##
# USE_ICONV - If set, this port uses libiconv.
# USE_GETTEXT - If set, this port uses GNU gettext (libintl).
##
@@ -384,7 +381,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Supported components are: glut, glu, glw, gl and linux.
# If set to "yes", this is equivalent to "glu". Note that
# glut depends on glu, glw and glu depend on gl.
-# USE_MOTIF - If set, this port uses a Motif toolkit. Implies USE_XPM.
+# USE_MOTIF - If set, this port uses a Motif toolkit. Implies USE_XORG+= xpm
# NO_OPENMOTIF - If set, this port uses a custom Motif toolkit
# instead of Openmotif.
# Used only when USE_MOTIF is set.
@@ -394,14 +391,13 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
##
# USE_SDL - If set, this port uses the sdl libraries.
# See bsd.sdl.mk for more information.
-# USE_XPM - If set, this port uses the xpm graphics libraries.
##
# USE_OPENSSL - If set, this port relies on the OpenSSL package.
##
# USE_OPENLDAP - If set, this port uses the OpenLDAP libraries.
# Implies: WANT_OPENLDAP_VER?=23
# WANT_OPENLDAP_VER
-# - Legal values are: 22, 23, 24
+# - Legal values are: 23, 24
# If set to an unkown value, the port is marked BROKEN.
# WANT_OPENLDAP_SASL
# - If set, the system should use OpenLDAP libraries
@@ -594,7 +590,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# - A command to install binary executables. (By
# default, also strips them, unless ${STRIP} is
# overridden to be the empty string).
-# INSTALL_KLD - As INSTALL_KLD, but without the STRIP.
+# INSTALL_KLD - As INSTALL_PROGRAM, but without the STRIP.
# INSTALL_SCRIPT
# - A command to install executable scripts.
# INSTALL_DATA - A command to install sharable data.
@@ -807,7 +803,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# FETCH_BINARY - Path to ftp/http fetch command if not in $PATH.
# Default: "/usr/bin/fetch"
# FETCH_ARGS - Arguments to ftp/http fetch command.
-# Default: "-ARr"
+# Default: "-ApRr"
# FETCH_CMD - ftp/http fetch command.
# Default: ${FETCH_BINARY} ${FETCH_ARGS}
# FETCH_BEFORE_ARGS
@@ -1129,13 +1125,13 @@ INDEXDIR?= ${PORTSDIR}
.else
-# Look for ${WRKSRC}/.../*.orig files, and (re-)create
+# Look for ${PATCH_WRKSRC}/.../*.orig files, and (re-)create
# ${FILEDIR}/patch-* files from them.
.if !target(makepatch)
makepatch:
@cd ${.CURDIR} && ${MKDIR} ${FILESDIR}
- @(cd ${WRKSRC}; \
+ @(cd ${PATCH_WRKSRC}; \
for i in `find . -type f -name '*.orig'`; do \
ORG=$$i; \
NEW=$${i%.orig}; \
@@ -1503,7 +1499,7 @@ PERL= ${LOCALBASE}/bin/perl
.include "${PORTSDIR}/Mk/bsd.gecko.mk"
.endif
-.if defined(WANT_GNOME) || defined(USE_GNOME) || defined(USE_GTK)
+.if defined(WANT_GNOME) || defined(USE_GNOME)
.include "${PORTSDIR}/Mk/bsd.gnome.mk"
.endif
@@ -1544,8 +1540,6 @@ PERL= ${LOCALBASE}/bin/perl
# Location of mounted CDROM(s) to search for files
CD_MOUNTPTS?= /cdrom ${CD_MOUNTPT}
-WANT_OPENLDAP_VER?= 23
-
# Owner and group of the WWW user
WWWOWN?= www
WWWGRP?= www
@@ -1689,26 +1683,8 @@ CONFIGURE_ENV+= MAKE=${GMAKE}
.include "${PORTSDIR}/Mk/bsd.gcc.mk"
.endif
-.if defined(USE_OPENLDAP_VER)
-USE_OPENLDAP?= yes
-WANT_OPENLDAP_VER= ${USE_OPENLDAP_VER}
-.endif
-
-.if defined(USE_OPENLDAP)
-.if defined(WANT_OPENLDAP_SASL)
-_OPENLDAP_FLAVOUR= -sasl
-.else
-_OPENLDAP_FLAVOUR=
-.endif
-.if ${WANT_OPENLDAP_VER} == 22
-LIB_DEPENDS+= ldap-2.2.7:${PORTSDIR}/net/openldap22${_OPENLDAP_FLAVOUR}-client
-.elif ${WANT_OPENLDAP_VER} == 23
-LIB_DEPENDS+= ldap-2.3.2:${PORTSDIR}/net/openldap23${_OPENLDAP_FLAVOUR}-client
-.elif ${WANT_OPENLDAP_VER} == 24
-LIB_DEPENDS+= ldap-2.4.3:${PORTSDIR}/net/openldap24${_OPENLDAP_FLAVOUR}-client
-.else
-IGNORE= cannot be built with unknown OpenLDAP version: ${WANT_OPENLDAP_VER}
-.endif
+.if defined(USE_OPENLDAP) || defined(WANT_OPENLDAP_VER)
+.include "${PORTSDIR}/Mk/bsd.ldap.mk"
.endif
.if defined(USE_FAM)
@@ -1833,7 +1809,7 @@ RUN_DEPENDS+= ${LINUX_BASE_PORT}
.endif
.if defined(USE_MOTIF)
-USE_XPM= yes
+USE_XORG+= xpm
.if defined(WANT_LESSTIF)
LIB_DEPENDS+= Xm:${PORTSDIR}/x11-toolkits/lesstif
NO_OPENMOTIF= yes
@@ -1879,7 +1855,7 @@ MAKE_ENV+= DISPLAY="localhost:1001"
.endif
.if defined(USE_XPM)
-USE_XORG+= xpm
+IGNORE= USE_XPM is deprecated. Use USE_XORG=xpm instead.
.endif
XAWVER= 8
@@ -2016,7 +1992,7 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.include "${PORTSDIR}/Mk/bsd.gecko.mk"
.endif
-.if defined(WANT_GNOME) || defined(USE_GNOME) || defined(USE_GTK)
+.if defined(WANT_GNOME) || defined(USE_GNOME)
.include "${PORTSDIR}/Mk/bsd.gnome.mk"
.endif
@@ -2256,7 +2232,7 @@ INSTALL_MACROS= BSD_INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
MAKE_ENV+= ${INSTALL_MACROS}
SCRIPTS_ENV+= ${INSTALL_MACROS}
-# Macro for coping entire directory tree with correct permissions
+# Macro for copying entire directory tree with correct permissions
.if ${UID} == 0
COPYTREE_BIN= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
2>&1) && \
@@ -2353,7 +2329,7 @@ ALL_TARGET?= all
INSTALL_TARGET?= install
# Popular master sites
-.include "bsd.sites.mk"
+.include "${PORTSDIR}/Mk/bsd.sites.mk"
# Empty declaration to avoid "variable MASTER_SITES recursive" error
MASTER_SITES?=