aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-04-10 12:31:02 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-04-10 12:31:02 +0000
commit7d2acfd09e1725ccfb44ddd83c3679ca0b762a88 (patch)
treeab4387e81433f3547433aed7001fc97468084f07 /Mk/bsd.port.mk
parentedd39ece4dcb30d77895a84de1fbe1ac91e8bd02 (diff)
downloadports-7d2acfd09e1725ccfb44ddd83c3679ca0b762a88.tar.gz
ports-7d2acfd09e1725ccfb44ddd83c3679ca0b762a88.zip
Add PKGNAMEPREFIX and PKGNAMESUFFIX - these are to be used in case the
package name includes "language specifics" or "compilation options" as specified in the handbook. PKGNAME is now defined as ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}. Suggested by: mharo (prefix), reg (suffix) Reviewed by: the ports list
Notes
Notes: svn path=/head/; revision=27438
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 7 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 24337731b686..7c8ee50a7bd4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -43,8 +43,11 @@ FreeBSD_MAINTAINER= asami@FreeBSD.org
#
# PORTNAME - Name of software.
# PORTVERSION - Version of software.
-# PKGNAME - Always defined as ${PORTNAME}-${PORTVERSION}. Do not
-# define this in your Makefile.
+# PKGNAMEPREFIX - Prefix to specify that port is language-specific, etc.
+# PKGNAMESUFFIX - Suffix to specify compilation options.
+# PKGNAME - Always defined as
+# ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}.
+# Do not define this in your Makefile.
# DISTNAME - Name of port or distribution used in generating
# WRKSRC and DISTFILES below (default:
# ${PORTNAME}-${PORTVERSION}).
@@ -1113,8 +1116,8 @@ FETCH_BEFORE_ARGS+= -l
@${ECHO} "${PKGNAME}: You need to define PORTNAME and PORTVERSION instead of PKGNAME."
@${FALSE}
.endif
-PKGNAME= ${PORTNAME}-${PORTVERSION}
-DISTNAME?= ${PKGNAME}
+PKGNAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+DISTNAME?= ${PORTNAME}-${PORTVERSION}
.else
# old style
PKGNAME?= ${DISTNAME}