aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-11-20 05:33:56 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-11-20 05:33:56 +0000
commit7dc47d3d6c65a76d99dcaf2e5f24c3e77fefeda5 (patch)
treeb3e0eff50b88481bd6aa79565b4eda15a7c83c04 /Mk/bsd.port.mk
parentcabb48a0101bbae50a1e4727d07f5194f5415ed1 (diff)
downloadports-7dc47d3d6c65a76d99dcaf2e5f24c3e77fefeda5.tar.gz
ports-7dc47d3d6c65a76d99dcaf2e5f24c3e77fefeda5.zip
Define MASTER_SITE_SUBDIR and PATCH_SITE_SUBDIR to default to "." so
we won't have double-slashes. Add support for new port variable MANUAL_PACKAGE_BUILD. If this is defined as well as the user variable PACKAGE_BUILDING, the port will be ignored. This is used to mark ports that can be built normally except on a machine that has a lot of conflicting ports (i.e., our package building machine).
Notes
Notes: svn path=/head/; revision=8716
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a9d878f59749..42b529e06f72 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.265 1997/10/08 05:04:48 asami Exp $
+# $Id: bsd.port.mk,v 1.266 1997/11/12 10:25:17 markm Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -564,6 +564,10 @@ MASTER_SITE_SUNSITE+= \
MASTER_SITES?=
PATCH_SITES?=
+# To avoid double-slashes
+MASTER_SITE_SUBDIR?= .
+PATCH_SITE_SUBDIR?= .
+
# Substitute subdirectory names
MASTER_SITES:= ${MASTER_SITES:S/%SUBDIR%/${MASTER_SITE_SUBDIR}/}
PATCH_SITES:= ${PATCH_SITES:S/%SUBDIR%/${PATCH_SITE_SUBDIR}/}
@@ -748,6 +752,12 @@ IGNORE= "uses X11, but ${X11BASE} not found"
IGNORE= "is marked as broken: ${BROKEN}"
.endif
+.if (defined(MANUAL_PACKAGE_BUILD) && defined(PACKAGE_BUILDING))
+IGNORE= "package has to be built manually: ${MANUAL_PACKAGE_BUILD}"
+clean:
+ @${IGNORECMD}
+.endif
+
.if defined(IGNORE)
.if defined(IGNORE_SILENT)
IGNORECMD= ${DO_NADA}