aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2018-03-03 06:50:15 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2018-03-03 06:50:15 +0000
commit8035da77dde0e788745129ab993d202bab92687e (patch)
treeea2e495f06fe058ab9efae69685de7de1fce6dd1 /Mk/bsd.port.mk
parentd0542b46be5d85c0dd3da0c422beee7cd84c53b3 (diff)
downloadports-8035da77dde0e788745129ab993d202bab92687e.tar.gz
ports-8035da77dde0e788745129ab993d202bab92687e.zip
* Add USE_GITLAB for fetching from www.gitlab.com and GitLab deployed sites.
Reviewed by: mat Approved by: portmgr (mat) Relnotes: yes Differential Revision: https://reviews.freebsd.org/D12162
Notes
Notes: svn path=/head/; revision=463463
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 14685d5b0f39..4f3f79a5e887 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1679,6 +1679,11 @@ DEV_WARNING+= "You are using USE_GITHUB and WRKSRC is set which is wrong. Set G
.endif
WRKSRC?= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}
.endif
+
+.if !default(IGNORE_MASTER_SITE_GITLAB) && defined(USE_GITLAB) && empty(USE_GITLAB:Mnodefault)
+WRKSRC?= ${WRKDIR}/${GL_PROJECT}-${GL_COMMIT}-${GL_COMMIT}
+.endif
+
# If the distname is not extracting into a specific subdirectory, have the
# ports framework force extract into a subdirectory so that metadata files
# do not get in the way of the build, and vice-versa.
@@ -2952,6 +2957,12 @@ DEPENDS_ARGS+= NOCLEANDEPENDS=yes
.endif
.endif
+.if defined(USE_GITLAB) && !${USE_GITLAB:Mnodefault} && empty(GL_COMMIT_DEFAULT)
+check-makevars::
+ @${ECHO_MSG} "GL_COMMIT is a required 40 character hash for use USE_GITLAB"
+ @${FALSE}
+.endif
+
################################################################
#
# Do preliminary work to detect if we need to run the config