aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-10-04 15:44:03 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-10-04 15:44:03 +0000
commit8ac604869e2e677d67acffbd008f87b8a0cad9d8 (patch)
treea3b9d99a78011dad77cbce48ecafe0998fd9c9e6 /Mk/bsd.port.mk
parent588065dbc6bbedd0a0f2f651fd16b1874f812fdf (diff)
downloadports-8ac604869e2e677d67acffbd008f87b8a0cad9d8.tar.gz
ports-8ac604869e2e677d67acffbd008f87b8a0cad9d8.zip
If GNU_CONFIGURE is set, pass `--prefix=${PREFIX}'; this should help
at least the GNU ports play nice with PREFIX.
Notes
Notes: svn path=/head/; revision=172
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index cde7ed7eb899..acb99413093f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.44 1994/10/04 14:44:56 jkh Exp $
+# $Id: bsd.port.mk,v 1.45 1994/10/04 14:46:34 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -48,6 +48,7 @@
# USE_GMAKE - Says that the port uses gmake.
# USE_IMAKE - Says that the port uses imake.
# HAS_CONFIGURE - Says that the port has its own configure script.
+# GNU_CONFIGURE - Set if you are using GNU configure (optional).
# CONFIGURE_ARGS - Pass these args to configure, if $HAS_CONFIGURE.
# DEPENDS - A list of other ports this package depends on being
# made first, relative to ${PORTSDIR} (e.g. x11/tk, lang/tcl,
@@ -143,6 +144,10 @@ PKGFILE?= ${PACKAGES}/${DISTNAME}${PKG_SUFX}
PKGFILE?= ${DISTNAME}${PKG_SUFX}
.endif
+.if defined(GNU_CONFIGURE)
+CONFIGURE_ARGS?= --prefix=${PREFIX}
+.endif
+
.MAIN: all
all: extract configure build