aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-09 08:53:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-09 08:53:12 +0000
commit93a599d772a31a2b37fe750a9a1e4be86742f5a5 (patch)
treed38882bc364e86fc36354f2f4afca3ae4bd67169 /Mk/bsd.port.mk
parent158887258bed126108dd34d736354a39053ef28d (diff)
downloadports-93a599d772a31a2b37fe750a9a1e4be86742f5a5.tar.gz
ports-93a599d772a31a2b37fe750a9a1e4be86742f5a5.zip
- Make WITH_FBSD10_FIX globally
- Add a new flag WITHOUT_FBSD10_FIX for maintainer testing Some additional notes: We are planing to make 10 exp-run after the 9.0 Release within 2 weeks to poke maintainers and upstream as to ensure that for the 10.0 Release, everything is fixed and we can remove the current workaround. Submitted by: bf@, rea@ (based on) Thanks to: beat, kwm, dough Reviewed by: erwin Tested via PH: 2x exp-run Approved by: portmgr (myself)
Notes
Notes: svn path=/head/; revision=285354
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk30
1 files changed, 17 insertions, 13 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 40f7b63bc973..82a77e3a1643 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -901,9 +901,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# target has not been overwritten). This message
# will be passed through /usr/bin/fmt before
# being shown to the user.
-# WITH_FBSD10_FIX - Replace freebsd1*) and similar conditions
-# with freebsd1.*) in configure and libtool
-# scripts to fix build on FreeBSD 10 and above.
+#
+# WITHOUT_FBSD10_FIX Disable FreeBSD 10.0 autotools workaround.
#
# For build and install:
#
@@ -3662,16 +3661,21 @@ do-patch:
.if !target(run-autotools-fixup)
run-autotools-fixup:
-# Work around an issue where FreeBSD 10.0 is detected as FreeBSD 1.x.
-.if defined(WITH_FBSD10_FIX) && ${OSVERSION} >= 1000000
- /bin/test -d ${WRKSRC} && find ${WRKSRC} -type f \( -name config.libpath -o \
- -name config.rpath -o -name configure -o -name libtool.m4 \) \
- -exec sed -i '' -e 's|freebsd1\*)|freebsd1.\*)|g' \
- -e 's|freebsd\[12\]\*)|freebsd[12].*)|g' \
- -e 's|freebsd\[123\]\*)|freebsd[123].*)|g' \
- -e 's|freebsd\[\[12\]\]\*)|freebsd[[12]].*)|g' \
- -e 's|freebsd\[\[123\]\]\*)|freebsd[[123]].*)|g' \
- {} + || /usr/bin/true
+# Work around an issue where FreeBSD 10.0 is detected as FreeBSD 1.x.
+.if ${OSVERSION} >= 1000000 && !defined(WITHOUT_FBSD10_FIX)
+ -@for f in `${FIND} ${WRKSRC} -type f \( -name config.libpath -o \
+ -name config.rpath -o -name configure -o -name libtool.m4 -o \
+ -name ltconfig -o -name libtool -o -name aclocal.m4 -o \
+ -name acinclude.m4 \)` ; do \
+ ${SED} -i.fbsd10bak \
+ -e 's|freebsd1\*)|freebsd1.\*)|g' \
+ -e 's|freebsd\[12\]\*)|freebsd[12].*)|g' \
+ -e 's|freebsd\[123\]\*)|freebsd[123].*)|g' \
+ -e 's|freebsd\[\[12\]\]\*)|freebsd[[12]].*)|g' \
+ -e 's|freebsd\[\[123\]\]\*)|freebsd[[123]].*)|g' \
+ $${f} ; \
+ ${TOUCH} ${TOUCH_FLAGS} -mr $${f}.fbsd10bak $${f} ; \
+ done
.endif
.endif