aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-30 19:25:46 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-30 19:25:46 +0000
commita245fe1498cad65d7a364849b208ff53a5d3a6f7 (patch)
treec03880dadc017bb964181cb364735cafab6d0f25 /Mk/bsd.port.mk
parent3075637e6f755767af4e106b6134500e1e761c61 (diff)
downloadports-a245fe1498cad65d7a364849b208ff53a5d3a6f7.tar.gz
ports-a245fe1498cad65d7a364849b208ff53a5d3a6f7.zip
* Split bsd.port.mk pre and post includes into 3 pieces instead of 2, to
allow OPTIONS to be able to influence dependencies. This is still experimental [1] * Teach bsd.gcc.mk about gfortran [2] * Remove the outdated emulators/linux_base; the new default has been linux_base-fc4. This will allow the outdated port to be removed [3] * Add USE_FIREBIRD macros to bsd.database.mk [4] PR: 93687 [1], 93690 [2], 103184 [3], 103357 [4] Submitted by: shaun [1], Pedro F. Giffuni <giffunip at asme to org> [2], gerald [2], thierry [2], vd [3], skv [4]
Notes
Notes: svn path=/head/; revision=174200
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk38
1 files changed, 20 insertions, 18 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ba5f9ebddf10..e2c18c77cf23 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1038,16 +1038,8 @@ makepatch:
.endif
-# Start of pre-makefile section.
-.if !defined(AFTERPORTMK)
-
-.if defined(_PREMKINCLUDED)
-check-makefile::
- @${ECHO_CMD} "${PKGNAME}: Makefile error: you cannot include bsd.port[.pre].mk twice"
- @${FALSE}
-.endif
-
-_PREMKINCLUDED= yes
+# Start of options section
+.if defined(INOPTIONSMK) || ( !defined(USEOPTIONSMK) && !defined(AFTERPORTMK) )
.if defined(MAKE_VERSION)
.if ${MAKE_VERSION} >= 5200408030 || ${MAKE_VERSION} >= 4200408030 && ${MAKE_VERSION} < 5000000000
@@ -1274,6 +1266,20 @@ WITHOUT_${W}:= true
. endif
.endif
+.endif
+
+
+# Start of pre-makefile section.
+.if !defined(AFTERPORTMK) && !defined(INOPTIONSMK)
+
+.if defined(_PREMKINCLUDED)
+check-makefile::
+ @${ECHO_CMD} "${PKGNAME}: Makefile error: you cannot include bsd.port[.pre].mk twice"
+ @${FALSE}
+.endif
+
+_PREMKINCLUDED= yes
+
# check for old, crufty, makefile types, part 1:
.if !defined(PORTNAME) || !( defined(PORTVERSION) || defined (DISTVERSION) ) || defined(PKGNAME)
check-makefile::
@@ -1581,7 +1587,7 @@ WWWGRP?= www
# End of pre-makefile section.
# Start of post-makefile section.
-.if !defined(BEFOREPORTMK)
+.if !defined(BEFOREPORTMK) && !defined(INOPTIONSMK)
.if defined(_POSTMKINCLUDED)
check-makefile::
@@ -1811,14 +1817,10 @@ USE_LINUX= ${OVERRIDE_LINUX_BASE_PORT}
. if exists(${PORTSDIR}/emulators/linux_base-${USE_LINUX})
LINUX_BASE_PORT= ${LINUXBASE}/bin/sh:${PORTSDIR}/emulators/linux_base-${USE_LINUX}
. else
-. if ${USE_LINUX} == "7"
-LINUX_BASE_PORT= ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base
-. else
-. if ${USE_LINUX:L} == "yes"
+. if ${USE_LINUX:L} == "yes"
LINUX_BASE_PORT= ${LINUXBASE}/etc/fedora-release:${PORTSDIR}/emulators/linux_base-fc4
-. else
+. else
IGNORE= There is no emulators/linux_base-${USE_LINUX}, perhaps wrong use of USE_LINUX or OVERRIDE_LINUX_BASE_PORT.
-. endif
. endif
. endif
@@ -1981,7 +1983,7 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
.if defined(USE_MYSQL) || defined(WANT_MYSQL_VER) || \
defined(USE_PGSQL) || defined(WANT_PGSQL_VER) || \
- defined(USE_BDB) || defined(USE_SQLITE)
+ defined(USE_BDB) || defined(USE_SQLITE) || defined(USE_FIREBIRD)
.include "${PORTSDIR}/Mk/bsd.database.mk"
.endif