aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-10-05 01:32:21 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-10-05 01:32:21 +0000
commita77f4b295738eaf089d47a05b98adc261c48d845 (patch)
tree043905f9df134321d2b895ec2d6404cafffe015b /Mk/bsd.port.mk
parent422a163013cb58ee4abbc92ac2619c92cccbd3cd (diff)
downloadports-a77f4b295738eaf089d47a05b98adc261c48d845.tar.gz
ports-a77f4b295738eaf089d47a05b98adc261c48d845.zip
Add bsd.gnome.mk that defines gnome-related dependency stuff and hooks
in bsd.port.mk to support it. In particular, bsd.port.mk includes bsd.gnome.mk twice (once in the pre.mk section, once in the post.mk section) and prints out a message notifying the user of the existence of WITH_* options when one exists. It also adds MAKE=${GMAKE} to CONFIGURE_ENV when USE_GMAKE is defined. (This is not related to gnome, but I assume it's useful somewhere and it shouldn't hurt.) Submitted by: ade, reg
Notes
Notes: svn path=/head/; revision=33415
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index cbe2396182c5..f0cbd3d7a464 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -729,6 +729,8 @@ MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
.endif
+.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+
# defaults to 3.3.6; will be changed to 4.0 when it is ready
XFREE86_VERSION?= 3
@@ -793,6 +795,7 @@ BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
.endif
.if defined(USE_GMAKE)
BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
+CONFIGURE_ENV+= MAKE=${GMAKE}
.endif
.if defined(USE_AUTOMAKE)
USE_AUTOCONF= yes
@@ -918,6 +921,8 @@ LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/XFree86-4-libraries
.endif
.endif
+.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+
.if exists(${PORTSDIR}/../Makefile.inc)
.include "${PORTSDIR}/../Makefile.inc"
.endif
@@ -2209,6 +2214,15 @@ post-${name}:
.endfor
+.if defined(GNOME_OPTION_MSG) && (!defined(PACKAGE_BUILDING) || !defined(BATCH))
+pre-everything:: echo-gnome-option-msg
+
+echo-gnome-option-msg:
+ @for m in ${GNOME_OPTION_MSG}; do \
+ ${ECHO_MSG} $$m; \
+ done
+.endif
+
# Patch-libtool
#
# Special target to automatically make libtool using ports use the