aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-10-11 09:25:58 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-10-11 09:25:58 +0000
commitae997f9df5715419de006f6b0eed5c65aa567622 (patch)
tree51095392d41b0361b8d61a8c1225790a2d2d270f /Mk/bsd.port.mk
parent4e1b29fbc6c3fc86c665721279410453e341c281 (diff)
downloadports-ae997f9df5715419de006f6b0eed5c65aa567622.tar.gz
ports-ae997f9df5715419de006f6b0eed5c65aa567622.zip
Add "--batch" to PATCH_ARGS and PATCH_DIST_ARGS when ${BATCH} is set
to avoid an infinite loop in patch when the patch target is not found and stdin is redirected from /dev/null (the "skip this patch? [n]" question).
Notes
Notes: svn path=/head/; revision=2318
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 36853128195b..ae301608c862 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.181 1995/10/04 11:13:52 asami Exp $
+# $Id: bsd.port.mk,v 1.165.2.2 1995/10/05 20:58:10 davidg Exp $
#
# Please view me with 4 column tabs!
@@ -265,6 +265,10 @@ PATCH_DIST_ARGS?= -d ${WRKSRC} -E ${PATCH_DIST_STRIP}
PATCH_ARGS?= -d ${WRKSRC} --forward --quiet -E ${PATCH_STRIP}
PATCH_DIST_ARGS?= -d ${WRKSRC} --forward --quiet -E ${PATCH_DIST_STRIP}
.endif
+.if defined(BATCH)
+PATCH_ARGS+= --batch
+PATCH_DIST_ARGS+= --batch
+.endif
.if defined(PATCH_CHECK_ONLY)
PATCH_ARGS+= -C