aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2010-05-25 00:25:02 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2010-05-25 00:25:02 +0000
commitaf3ccd0db3b59ab49f97cecf20273bfcd3d3cc15 (patch)
tree283b3c790b061312fab9915dab9cb23c6ceec417 /Mk/bsd.port.mk
parent3c72f3083ebc140e6e56cf7f13af8fc17776518f (diff)
downloadports-af3ccd0db3b59ab49f97cecf20273bfcd3d3cc15.tar.gz
ports-af3ccd0db3b59ab49f97cecf20273bfcd3d3cc15.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk17
1 files changed, 13 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c6e6d5a4f8d7..90fd37a11003 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2493,6 +2493,9 @@ MOTIFLIB?= -L${X11BASE}/lib -lXm -lXp
ALL_TARGET?= all
INSTALL_TARGET?= install
+# Integrate with the license auditing framework
+.include "${PORTSDIR}/Mk/bsd.licenses.mk"
+
# Popular master sites
.include "${PORTSDIR}/Mk/bsd.sites.mk"
@@ -3308,6 +3311,8 @@ ignorelist-verbose:
# Clean directories for ftp or CDROM.
################################################################
+.if !defined(LICENSE)
+
.if defined(RESTRICTED)
clean-restricted: delete-distfiles delete-package
clean-restricted-list: delete-distfiles-list delete-package-list
@@ -3326,6 +3331,8 @@ clean-for-cdrom:
clean-for-cdrom-list:
.endif
+.endif # !defined(LICENSE)
+
.if defined(ALL_HOOK)
all:
@cd ${.CURDIR} && ${SETENV} CURDIR=${.CURDIR} DISTNAME=${DISTNAME} \
@@ -4331,7 +4338,8 @@ _CHROOT_SEQ=
_SANITY_SEQ= ${_CHROOT_SEQ} pre-everything check-makefile \
check-categories check-makevars check-desktop-entries \
check-conflicts check-depends check-deprecated \
- check-vulnerable buildanyway-message options-message
+ check-vulnerable check-license buildanyway-message \
+ options-message
_FETCH_DEP= check-sanity
_FETCH_SEQ= fetch-depends pre-fetch pre-fetch-script \
do-fetch post-fetch post-fetch-script
@@ -4340,7 +4348,7 @@ _EXTRACT_SEQ= extract-message checksum extract-depends pre-extract \
pre-extract-script do-extract \
post-extract post-extract-script
_PATCH_DEP= extract
-_PATCH_SEQ= patch-message patch-depends patch-dos2unix pre-patch \
+_PATCH_SEQ= ask-license patch-message patch-depends patch-dos2unix pre-patch \
pre-patch-script do-patch post-patch post-patch-script
_CONFIGURE_DEP= patch
_CONFIGURE_SEQ= build-depends lib-depends configure-message \
@@ -4354,8 +4362,9 @@ _INSTALL_SEQ= install-message run-depends lib-depends apply-slist pre-install \
pre-install-script generate-plist check-already-installed
_INSTALL_SUSEQ= check-umask install-mtree pre-su-install \
pre-su-install-script create-users-groups do-install \
- install-desktop-entries post-install post-install-script \
- add-plist-info add-plist-docs add-plist-examples add-plist-data \
+ install-desktop-entries install-license \
+ post-install post-install-script add-plist-info \
+ add-plist-docs add-plist-examples add-plist-data \
add-plist-post install-rc-script compress-man \
install-ldconfig-file fake-pkg security-check
_PACKAGE_DEP= install