aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-04-01 11:13:00 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-04-01 11:13:00 +0000
commitbb0cc862808f4fae90610d97613b7f17e3845b2a (patch)
treea73384de5d4a0219c324c0c978dbb87fe5d8cdfe /Mk/bsd.port.mk
parent3c19fb28d34a111381bfd61db994e0c8a86f5268 (diff)
downloadports-bb0cc862808f4fae90610d97613b7f17e3845b2a.tar.gz
ports-bb0cc862808f4fae90610d97613b7f17e3845b2a.zip
Thanks for the overwhelming response (which can be only summarized by the
word: "zilch"). I guess the only way to get people try and comment on these kind of things is to shove it down their throat.... ;) Anyway, here's a set of changes required for auto-generation of READMEs in ports directories. Necessary changes and additions of templates to the ports tree will follow shortly. Eventually I'll commit all the generated READMEs to the tree, but that will be in the rather distant future. For now, I encourage anyone with a -current systam and a matching ports tree to do a "make readmes" at the top level and see what they get. Next step will be to add pkg/{COMMENT,DESCR} to all the categories.
Notes
Notes: svn path=/head/; revision=2931
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk46
1 files changed, 43 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 81440f48d353..d83674b50175 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.197 1996/03/31 10:02:09 asami Exp $
+# $Id: bsd.port.mk,v 1.198 1996/03/31 10:35:26 asami Exp $
#
# Please view me with 4 column tabs!
@@ -198,6 +198,7 @@ LOCALBASE?= /usr/local
X11BASE?= /usr/X11R6
DISTDIR?= ${PORTSDIR}/distfiles/${DIST_SUBDIR}
PACKAGES?= ${PORTSDIR}/packages
+TEMPLATES?= ${PORTSDIR}/templates
.if !defined(NO_WRKDIR)
WRKDIR?= ${.CURDIR}/work
.else
@@ -323,6 +324,7 @@ PKG_SUFX?= .tgz
PKG_DBDIR?= /var/db/pkg
ECHO?= /bin/echo
+CAT+= /bin/cat
CP?= /bin/cp
ENV?= /usr/bin/env
RM?= /bin/rm
@@ -974,10 +976,8 @@ checksum: fetch
.if !target(package-name)
package-name:
-.if !defined(NO_PACKAGE)
@${ECHO} ${PKGNAME}
.endif
-.endif
# Show (recursively) all the packages this package depends on.
@@ -1172,6 +1172,46 @@ describe:
@${ECHO} ""
.endif
+.if !target(readmes)
+readmes: readme
+.endif
+
+.if !target(readme)
+readme:
+ @rm -f README.html
+ @make README.html
+.endif
+
+README.html:
+ @${ECHO_MSG} "===> Creating README.html for ${PKGNAME}"
+ @${CAT} ${TEMPLATES}/README.port | \
+ ${SED} -e 's%%PORT%%'`${ECHO} ${.CURDIR} | ${SED} -e 's.*/\([^/]*/[^/]*\)$$\1'`'g' \
+ -e 's%%PKG%%${PKGNAME}g' \
+ -e '/%%COMMENT%%/r${PKGDIR}/COMMENT' \
+ -e '/%%COMMENT%%/d' \
+ -e 's%%BUILD_DEPENDS%%'"`${MAKE} print-depends-list`"'' \
+ -e 's%%RUN_DEPENDS%%'"`${MAKE} print-package-depends`"'' \
+ >> $@
+
+.if !target(print-depends-list)
+print-depends-list:
+.if defined(FETCH_DEPENDS) || defined(BUILD_DEPENDS) || \
+ defined(LIB_DEPENDS) || defined(DEPENDS)
+ @${ECHO} -n 'This port requires package(s) "'
+ @${ECHO} -n `make depends-list | sort | uniq`
+ @${ECHO} '" to build.'
+.endif
+.endif
+
+.if !target(print-package-depends)
+print-package-depends:
+.if defined(RUN_DEPENDS) || defined(LIB_DEPENDS) || defined(DEPENDS)
+ @${ECHO} -n 'This port requires package(s) "'
+ @${ECHO} -n `make package-depends | sort | uniq`
+ @${ECHO} '" to run.'
+.endif
+.endif
+
# Fake installation of package so that user can pkg_delete it later.
# Also, make sure that an installed port is recognized correctly in
# accordance to the @pkgdep directive in the packing lists