aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-24 10:04:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-24 10:04:22 +0000
commitc2d1a328f9cfecb52c168d2e56870022a202461a (patch)
tree3470dc1a6164392511f7b20f83f4c37c6d340e24 /Mk/bsd.port.mk
parent898b5242b0694243cc477605662c06ba79deafd6 (diff)
downloadports-c2d1a328f9cfecb52c168d2e56870022a202461a.tar.gz
ports-c2d1a328f9cfecb52c168d2e56870022a202461a.zip
Define UID earlier so that it can be used by USES
Notes
Notes: svn path=/head/; revision=328104
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bb20c4074ae2..a21b3075b0a0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1489,6 +1489,10 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
USES+= gmake
.endif
+.if !defined(UID)
+UID!= ${ID} -u
+.endif
+
# Loading features
.for f in ${USES}
_f=${f:C/\:.*//g}
@@ -1620,10 +1624,6 @@ PATCH_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
.endif
.endif
-.if !defined(UID)
-UID!= ${ID} -u
-.endif
-
# Check the compatibility layer for amd64/ia64
.if ${ARCH} == "amd64" || ${ARCH} =="ia64"