aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-09 10:37:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-09 10:37:03 +0000
commitc3f673a223b029873a4625dfbd7c74de0430f1fb (patch)
tree5d82425c469e8149d922801297a40347fd866aa0 /Mk/bsd.port.mk
parentfce62e4059d50ecb0504456df1aa34eb42b03fae (diff)
downloadports-c3f673a223b029873a4625dfbd7c74de0430f1fb.tar.gz
ports-c3f673a223b029873a4625dfbd7c74de0430f1fb.zip
Introduce a new USE_CXXSTD similar to USE_CSTD to allow enforcing the C++ language standard to use when building a port
Notes
Notes: svn path=/head/; revision=326801
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 88b515993409..843924d9b884 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -319,6 +319,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_GCC - If set, this port requires this version of gcc, either in
# the system or installed from a port.
# USE_CSTD - Override the default C language standard (gnu89, gnu99)
+# USE_CXXSTD Override the default C++ language standard
# USE_BINUTILS - Use binutils suite from port instead of the version in base.
##
# USE_GHOSTSCRIPT
@@ -2128,6 +2129,10 @@ CFLAGS+= -fno-strict-aliasing
CFLAGS:= ${CFLAGS:N-std=*} -std=${USE_CSTD}
.endif
+.if defined(USE_CXXSTD)
+CXXFLAGS:= ${CXXFLAGS:N-std=*} -std=${USE_CXXSTD}
+.endif
+
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
_MAKE_JOBS= #