aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-05-14 14:33:34 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-05-14 14:33:34 +0000
commitc671212915bf451f0b3636cb9ee5f152cef07428 (patch)
tree2557a15788e94600b2f0d7905e5684d2b39a8654 /Mk/bsd.port.mk
parent8201a7ecc798aa0d8d27c278873ae8ac7d44525c (diff)
downloadports-c671212915bf451f0b3636cb9ee5f152cef07428.tar.gz
ports-c671212915bf451f0b3636cb9ee5f152cef07428.zip
Add PATCH_CONTINUE_ON_FAIL to allow patching to go through all the
patches even if one fail. This helps when upgrading ports with a large number of patches, like www/chromium where having to fix one patch, re-do the patching, fix the fallout, 800 times, is really painful. This fixes the first attempt at this which would make ports with multiple patches patching one file somewhat explode.
Notes
Notes: svn path=/head/; revision=535241
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 116015aeb3be..5abbf8525c2a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3188,6 +3188,7 @@ do-patch:
dp_PATCH_ARGS=${PATCH_ARGS:Q} \
dp_PATCH_DEBUG_TMP="${PATCH_DEBUG_TMP}" \
dp_PATCH_DIST_ARGS="${PATCH_DIST_ARGS}" \
+ dp_PATCH_CONTINUE_ON_FAIL=${PATCH_CONTINUE_ON_FAIL:Dyes} \
dp_PATCH_SILENT="${PATCH_SILENT}" \
dp_PATCH_WRKSRC=${PATCH_WRKSRC} \
dp_PKGNAME="${PKGNAME}" \