aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2019-12-08 10:19:38 +0000
committerLars Engels <lme@FreeBSD.org>2019-12-08 10:19:38 +0000
commitc86f12f75f1427b99c54ecbf03b70bb14389154f (patch)
tree6c0c0be7554989e8fc51226fb47f02ae9dc40c16 /Mk/bsd.port.mk
parent35b6cb86f91f6add5662ddbf48f3bf79a0569bee (diff)
downloadports-c86f12f75f1427b99c54ecbf03b70bb14389154f.tar.gz
ports-c86f12f75f1427b99c54ecbf03b70bb14389154f.zip
Add new Makefile target "install-missing-packages" to install missing dependencies from packages.
Approved by: portmgr (bapt) Differential Revision: https://reviews.freebsd.org/D22551
Notes
Notes: svn path=/head/; revision=519284
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d180ebeb8d34..7b076c915492 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -603,7 +603,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# test-depends-list
# - Show all directories which are test-dependencies
# for this port.
-#
+# install-missing-packages
+# - Install missing dependencies from package and mark
+# them as automatically installed
# extract - Unpacks ${DISTFILES} into ${WRKDIR}.
# patch - Apply any provided patches to the source.
# configure - Runs either GNU configure, one or more local configure
@@ -4319,6 +4321,11 @@ missing-packages:
fi; \
done
+# Install missing dependencies from package
+install-missing-packages:
+ @_dirs=$$(${MISSING-DEPENDS-LIST}); \
+ ${PKG_BIN} install -A $$(${ECHO} $${_dirs} | ${SED} "s%${PORTSDIR}/%%g")
+
################################################################
# Everything after here are internal targets and really
# shouldn't be touched by anybody but the release engineers.