aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-08-29 11:24:50 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-08-29 11:24:50 +0000
commitde955f45ab0c413dfcd4f5c8874041246928123a (patch)
tree7d81e7579455a0cca3d3cfb59e309aa0e570bc97 /Mk/bsd.port.mk
parent18f8b446780c0a4cfed7ce8ca790036e35253b87 (diff)
downloadports-de955f45ab0c413dfcd4f5c8874041246928123a.tar.gz
ports-de955f45ab0c413dfcd4f5c8874041246928123a.zip
Clean up EXTRACT_ONLY logic a bit. Instead of branching in the
do-extract target depending on defined(EXTRACT_ONLY) or not, simply set EXTRACT_ONLY ?= ${DISTFILES} and always use ${EXTRACT_ONLY} as the extraction list.
Notes
Notes: svn path=/head/; revision=2128
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk15
1 files changed, 5 insertions, 10 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 46994c4a5bfb..b6b416752de4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.174 1995/07/24 08:02:07 asami Exp $
+# $Id: bsd.port.mk,v 1.175 1995/08/18 10:06:28 asami Exp $
#
# Please view me with 4 column tabs!
@@ -329,6 +329,10 @@ PATCHDIST:= ${DISTDIR}
DISTFILES?= ${DISTNAME}${EXTRACT_SUFX}
PKGNAME?= ${DISTNAME}
+# This is what is actually going to be extracted, and is overridable
+# by user.
+EXTRACT_ONLY?= ${DISTFILES}
+
# Documentation
MAINTAINER?= ports@FreeBSD.ORG
CATEGORIES?= orphans
@@ -491,21 +495,12 @@ do-fetch:
do-extract:
@/bin/rm -rf ${WRKDIR}
@/bin/mkdir -p ${WRKDIR}
-.if defined(EXTRACT_ONLY)
@for file in ${EXTRACT_ONLY}; do \
if ! (cd ${WRKDIR};${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
then \
exit 1; \
fi \
done
-.else
- @for file in ${DISTFILES}; do \
- if ! (cd ${WRKDIR};${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
- then \
- exit 1; \
- fi \
- done
-.endif
.endif
# Patch