aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-11-18 19:48:21 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-11-18 19:48:21 +0000
commite1e16dd2af175d8718cbabcabac2c75fb7b9023f (patch)
treea4d7ce97b8ce4ff90afeaeb8e36ac04c16a22d7f /Mk/bsd.port.mk
parent7ba3f1a7055fac78cea119f2a79b928b2f836230 (diff)
downloadports-e1e16dd2af175d8718cbabcabac2c75fb7b9023f.tar.gz
ports-e1e16dd2af175d8718cbabcabac2c75fb7b9023f.zip
Add the ability to build specific ports with WITH_DEBUG
Reviewed by: Ilya A. Arkhipov <rum1cro@yandex.ru> Reviewed by: bsam Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=334256
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index fe0721e42403..fa739730909e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -311,6 +311,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# passed to the compiler by setting DEBUG_FLAGS. It is
# set to "-g" at default.
#
+# WITH_DEBUG_PORTS - A list of origins for which WITH_DEBUG will be set
+#
# WITH_SSP_PORTS
# - If set, SSP_FLAGS (defaults to -fstack-protector)
# is added to CFLAGS and the necessary flags
@@ -1303,6 +1305,12 @@ MAKE_ENV+= TMPDIR="${TMPDIR}"
CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
.endif # defined(TMPDIR)
+.if defined(WITH_DEBUG_PORTS)
+.if ${WITH_DEBUG_PORTS:M${PKGORIGIN}}
+WITH_DEBUG= yes
+.endif
+.endif
+
# Reset value from bsd.own.mk.
.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
STRIP= #none