aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2019-11-20 22:44:38 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2019-11-20 22:44:38 +0000
commite4f098d6a0be1bf6cae37f6259f69a7303beee11 (patch)
tree5133dfc2e876b3249ae22d5431388b56821fbbd2 /Mk/bsd.port.mk
parentb92b93b0ce8587582ae1cbf5e9223ee362ecae42 (diff)
downloadports-e4f098d6a0be1bf6cae37f6259f69a7303beee11.tar.gz
ports-e4f098d6a0be1bf6cae37f6259f69a7303beee11.zip
Permit multiple packing list files to be listed in PLIST.
This permits a port to use separate packing lists for optional components instead of depending on PLIST_SUB. Approved by: portmgr (bapt) Differential Revision: https://reviews.freebsd.org/D22450
Notes
Notes: svn path=/head/; revision=518058
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ebac68554f7c..d5d325d26a1a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4464,9 +4464,11 @@ generate-plist: ${WRKDIR}
${ECHO_CMD} $${file} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} >> ${TMPPLIST}; \
done
.if !empty(PLIST)
- @if [ -f ${PLIST} ]; then \
- ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PLIST} >> ${TMPPLIST}; \
+.for f in ${PLIST}
+ @if [ -f "${f}" ]; then \
+ ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${f} >> ${TMPPLIST}; \
fi
+.endfor
.endif
.for dir in ${PLIST_DIRS}