aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-10-20 17:07:23 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-10-20 17:07:23 +0000
commite7718f19b1cdb126ca2e45c9c664c04df407dba8 (patch)
tree13f89d7a8fcd55510593f060e4cf43d6e76d6ddb /Mk/bsd.port.mk
parente06b47fa2bd0257bd508c27c45dd529eba9508eb (diff)
downloadports-e7718f19b1cdb126ca2e45c9c664c04df407dba8.tar.gz
ports-e7718f19b1cdb126ca2e45c9c664c04df407dba8.zip
FLAVORS: Fix 'make clean' not respecting passed in FLAVOR.
With hat: portmgr
Notes
Notes: svn path=/head/; revision=452543
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 88a35396a5dd..b02960c31d76 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1061,6 +1061,10 @@ STAGEDIR?= ${WRKDIR}/stage
NOTPHONY?=
FLAVORS?=
FLAVOR?=
+# Store env FLAVOR for later
+.if !defined(_FLAVOR)
+_FLAVOR:= ${FLAVOR}
+.endif
# XXX: We have no real FLAVORS support in ports or tools yet.
#PORTS_FEATURES+= FLAVORS
MINIMAL_PKG_VERSION= 1.6.0
@@ -3748,7 +3752,12 @@ post-clean-noflavor:
clean: ${CLEAN_DEPENDENCIES}
.endif
-.for _f in ${FLAVORS}
+.if !empty(_FLAVOR)
+_CLEANFLAVORS= ${_FLAVOR}
+.else
+_CLEANFLAVORS= ${FLAVORS}
+.endif
+.for _f in ${_CLEANFLAVORS}
CLEAN_DEPENDENCIES=
.if !defined(NOCLEANDEPENDS)
CLEAN_DEPENDENCIES+= limited-clean-depends-${_f}