aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-06-07 13:25:22 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-06-07 13:25:22 +0000
commitfb58afc3dde8a4a941b5ce9130296bf13429394f (patch)
tree075b2bf548b3873c405f3b47513c0f8d12b423c6 /Mk/bsd.port.mk
parent95e500d638e2ed2f127e68a8babf5ca028e271ae (diff)
downloadports-fb58afc3dde8a4a941b5ce9130296bf13429394f.tar.gz
ports-fb58afc3dde8a4a941b5ce9130296bf13429394f.zip
Add WRKSRC_SUBDIR to simplify overriding WRKSRC:
WRKSRC= ${WRKDIR}/${DISTNAME}/src This becomes: WRKSRC_SUBDIR= src Reviewed by: bapt With hat: portmgr
Notes
Notes: svn path=/head/; revision=320199
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0ef87d6fe6c9..c9221e5ff058 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -568,6 +568,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# unpacks to.
# Default: ${WRKDIR}/${DISTNAME} unless NO_WRKSUBDIR is set,
# in which case simply ${WRKDIR}
+# WRKSRC_SUBDIR - A subdirectory of ${WRKSRC} where the distribution actually
+# build in.
+# Default: not set
# NO_WRKSUBDIR - Assume port unpacks directly into ${WRKDIR}.
# PATCHDIR - A directory containing any additional patches you made
# to port this software to FreeBSD.
@@ -1543,6 +1546,9 @@ WRKSRC?= ${WRKDIR}
.else
WRKSRC?= ${WRKDIR}/${DISTNAME}
.endif
+.if defined(WRKSRC_SUBDIR)
+WRKSRC:= ${WRKSRC}/${WRKSRC_SUBDIR}
+.endif
PATCH_WRKSRC?= ${WRKSRC}
CONFIGURE_WRKSRC?= ${WRKSRC}