aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-01-23 23:54:22 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-01-23 23:54:22 +0000
commit18ad5ce26ed5534dc584696bfd13635c1b73410d (patch)
treea977c2fce819ac90ed07516075e67fcbea18104e /Mk/bsd.port.subdir.mk
parentc8276f2dd33922b0cbbadc0fc874969e3a6c147c (diff)
downloadports-18ad5ce26ed5534dc584696bfd13635c1b73410d.tar.gz
ports-18ad5ce26ed5534dc584696bfd13635c1b73410d.zip
Fix 'make search' on 4.X. Has no effect on 5.X and 6.X which worked
correctly to start with. NOTE: if you have your ports tree outside of /usr/ports and don't make your own INDEX, 'make search' will return no results. This was a pre-existing problem which no one had ever noticed. People with long experience in software can imagine the merriment of attempting to debug the current problem given this, for themselves. PR: ports/92189 Submitted by: linimon Fix from clement
Notes
Notes: svn path=/head/; revision=154299
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 7c33e35257aa..6f0a5b884839 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -406,12 +406,16 @@ _PORTSEARCH= \
fields["rdeps"] = 9; names[9] = "R-deps"; \
fields["www"] = 10; names[10] = "WWW"; \
split(display, d, /,[ \t]*/); \
- for (i in d) { \
- disp[fields[d[i]]] = 1; \
- } \
split(xdisplay, xd, /,[ \t]*/); \
- for (i in xd) { \
- delete disp[fields[xd[i]]]; \
+ for (i in d) { \
+ toprint = 1;\
+ for (j in xd) { \
+ if (d[i] == xd[j] ) { \
+ toprint=0; \
+ break;\
+ }\
+ } \
+ if (toprint == 1 ) disp[fields[d[i]]] = 1; \
} \
} \
{ \