aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-08-22 10:46:38 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-08-22 10:46:38 +0000
commit72d8a92acaf54f56f099deec45d475426c7094b4 (patch)
tree55ea23f5095f6e41f9eaa6d4a4c344ef4f4ffc63 /Mk/bsd.port.subdir.mk
parentd0451777b8d1288001be78d1c453a02cf8a4ba30 (diff)
downloadports-72d8a92acaf54f56f099deec45d475426c7094b4.tar.gz
ports-72d8a92acaf54f56f099deec45d475426c7094b4.zip
I had to bite the bullet: There's now a port.subdir.mk that does the right
thing with recursive build, configure, bundle or extract targets. Reviewed by: Submitted by:
Notes
Notes: svn path=/head/; revision=18
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk84
1 files changed, 84 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
new file mode 100644
index 000000000000..16bba7c802b8
--- /dev/null
+++ b/Mk/bsd.port.subdir.mk
@@ -0,0 +1,84 @@
+# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
+# $Id$
+
+.MAIN: all
+
+STRIP?= -s
+
+BINGRP?= bin
+BINOWN?= bin
+BINMODE?= 555
+
+_SUBDIRUSE: .USE
+ @for entry in ${SUBDIR}; do \
+ (if test -d ${.CURDIR}/$${entry}.${MACHINE}; then \
+ echo "===> ${DIRPRFX}$${entry}.${MACHINE}"; \
+ edir=$${entry}.${MACHINE}; \
+ cd ${.CURDIR}/$${edir}; \
+ else \
+ echo "===> ${DIRPRFX}$$entry"; \
+ edir=$${entry}; \
+ cd ${.CURDIR}/$${edir}; \
+ fi; \
+ ${MAKE} ${.TARGET:realinstall=install} DIRPRFX=${DIRPRFX}$$edir/); \
+ done
+
+${SUBDIR}::
+ @if test -d ${.TARGET}.${MACHINE}; then \
+ cd ${.CURDIR}/${.TARGET}.${MACHINE}; \
+ else \
+ cd ${.CURDIR}/${.TARGET}; \
+ fi; \
+ ${MAKE} all
+
+.if !target(all)
+all: _SUBDIRUSE
+.endif
+
+.if !target(extract)
+extract: _SUBDIRUSE
+.endif
+
+.if !target(configure)
+configure: _SUBDIRUSE
+.endif
+
+.if !target(build)
+build: _SUBDIRUSE
+.endif
+
+.if !target(clean)
+clean: _SUBDIRUSE
+.endif
+
+.if !target(depend)
+depend: _SUBDIRUSE
+.endif
+
+.if !target (maninstall)
+maninstall: _SUBDIRUSE
+.endif
+
+.if !target(install)
+.if !target(beforeinstall)
+beforeinstall:
+.endif
+.if !target(afterinstall)
+afterinstall:
+.endif
+install: afterinstall
+afterinstall: realinstall
+realinstall: beforeinstall _SUBDIRUSE
+.endif
+
+.if !target(lint)
+lint: _SUBDIRUSE
+.endif
+
+.if !target(obj)
+obj: _SUBDIRUSE
+.endif
+
+.if !target(tags)
+tags: _SUBDIRUSE
+.endif