aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-09-16 14:30:22 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-09-16 14:30:22 +0000
commitc866f155afbba81070330a1fbebc13266ec7672e (patch)
tree0489b20093a86243da7821acd5eb90b43be3c5bc /Mk/bsd.port.subdir.mk
parentbb7ebed9d6284e20346481e99bbb483cd62bbe9e (diff)
downloadports-c866f155afbba81070330a1fbebc13266ec7672e.tar.gz
ports-c866f155afbba81070330a1fbebc13266ec7672e.zip
Add support for DEBUG_FLAGS. If you say something like:
make DEBUG_FLAGS=-g2 You can compile something for debugging at debugging level 2. It will also take care not to strip the resulting executable(s).
Notes
Notes: svn path=/head/; revision=101
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index ef3e5671dfd2..ce81a18a5d97 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,9 +1,11 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
-# $Id: bsd.port.subdir.mk,v 1.3 1994/08/22 13:02:16 jkh Exp $
+# $Id: bsd.port.subdir.mk,v 1.4 1994/09/14 16:42:37 jkh Exp $
.MAIN: all
+.if !defined(DEBUG_FLAGS)
STRIP?= -s
+.endif
BINGRP?= bin
BINOWN?= bin