aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-20 04:11:09 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-20 04:11:09 +0000
commitd76beff66d80c6a6601df0b9002c9cfde6680ac6 (patch)
treef32538af0c01613d3a24b589a5a4cbb94a049e8f /Mk/bsd.port.subdir.mk
parent4177135638cc8d30881ba8226a147cdfbbe0da51 (diff)
downloadports-d76beff66d80c6a6601df0b9002c9cfde6680ac6.tar.gz
ports-d76beff66d80c6a6601df0b9002c9cfde6680ac6.zip
Do not choke on an empty SUBDIR.
Submitted by: sada (slightly altered)
Notes
Notes: svn path=/head/; revision=70531
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index e677ea728e05..e7523af8a6b9 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -96,10 +96,16 @@ TARGETS+= tags
.for __target in ${TARGETS}
.if !target(${__target})
+.if defined(SUBDIR) && !empty(SUBDIR)
${__target}: ${SUBDIR:S/$/.${__target}/}
+.else
+${__target}:
+.endif
.endif
.endfor
+.if defined(SUBDIR) && !empty(SUBDIR)
+
.for __target in ${TARGETS} checksubdirs readmes
${SUBDIR:S/$/.${__target}/}: _SUBDIRUSE
.endfor
@@ -129,6 +135,8 @@ _SUBDIRUSE: .USE
${SUBDIR}:: ${SUBDIR:S/$/.all/}
+.endif
+
.if !target(install)
.if !target(beforeinstall)
beforeinstall: