aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-07 08:51:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-07 08:51:46 +0000
commiteb67234c29b2a3b1d550631096380a0e2511ca23 (patch)
tree10eba729db3596fc4d265c5ba3412b1252ed46ce /Mk/bsd.port.subdir.mk
parente600bd8ea2ff25f1ba678ca7ac599ef6d8678f70 (diff)
downloadports-eb67234c29b2a3b1d550631096380a0e2511ca23.tar.gz
ports-eb67234c29b2a3b1d550631096380a0e2511ca23.zip
* Improve the test for the old ports directory layout [1]
* Include SITE_PERL earlier [2] * Use the correct versions of autoconf and automake [3] * Add a PORTDOCS macro for automating installation of documentation files [4] * Define a default Fortran compiler for each version of USE_GCC [5] * Fix package builds when WRKDIRPREFIX is set [6] * Add more comment documentation on default targets [7] * Fix plist generation in certain cases [8] * Fix COMMENT/COMMENTFILE checking [9] * Use SU_CMD for deinstall and deinstall-all targets (provided INSTALL_AS_USER is not set) [10] * Define a default WWWOWN and WWWGRP [11] * Make INDEX builds work even when the port name is the same as a default target [12] * Fix the new share/nls/C links [13] * Don't look in ${LOCALBASE}/lib/compat/pkg for LIB_DEPENDS [14] * Document package-recursive [15] * Create a new virtual category, lisp [16] * Create a new real category, arabic * Add a new GCCVERSION macro for eaisly tracking compiler version changes [17] * Abstract out some of the common Apache bits [18] * Enable the use of USE_OPENLDAP after including bsd.port.pre.mk [19] * Add a new virtual category, pear [20] * Add support for randomizing MASTER_SITES [21] * Don't accept PORTVERSIONS that pkg_version can't handle [22] * Add support for dynamic pkg-install, pkg-deinstall, pkg-message, and pkg-req scripts [23] * Don't redirect stderr when running pkg_info -O. This may help troubleshoot mysterious "Error 1" messages. * Fix up the order of the various PKGNAME related macros to be consistent with portlint [24] PR: 21885 [1] 51588 [2] 55325 [3] 57778 [4] 55674 [5] 56096 [6] 56355 [7] 56533 [8] 57272 [9] 57378 [10] 57403 [11] 57438 [12] 57488 [13] 57664 [14] 57928 [15] 58232 [16] 58317 [17] 32604 [18] 57529 [19] 56582 [20] 48377 [21] 56960 [22] 58885 [23] 54351 [24] Submitted by: trevor [1] eik@fillmore-labs.com [2] rehsack@liwing.de, ade [3] eikemeier@fillmore-labs.com [4] thierry@pompo.net [5] Palle Girgensohn <girgen@pingpong.net> [6] edwin [7] leeym [8] edwin [9] fjoe [10] edwin [11] eikemeier@fillmore-labs.com [12] fuyuki@nigredo.org [13] eikemeier@fillmore-labs.com [14] freebsd@generalresources.com [15] linimon [16] linimon [17] dinoex [18] eikemeier@fillmore-labs.com [19] edwin [20] seanc [21] eikemeier@fillmore-labs.com [22] Reviewed by: eikemeier@fillmore-labs.com [23]
Notes
Notes: svn path=/head/; revision=93291
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 7c27c594f5d1..6164c6f3b5c0 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -99,7 +99,7 @@ TARGETS+= tags
.for __target in ${TARGETS}
.if !target(${__target})
.if defined(SUBDIR) && !empty(SUBDIR)
-${__target}: ${SUBDIR:S/$/.${__target}/}
+${__target}: ${SUBDIR:S/^/_/:S/$/.${__target}/}
.else
${__target}:
.endif
@@ -109,18 +109,18 @@ ${__target}:
.if defined(SUBDIR) && !empty(SUBDIR)
.for __target in ${TARGETS} checksubdirs readmes
-${SUBDIR:S/$/.${__target}/}: _SUBDIRUSE
+${SUBDIR:S/^/_/:S/$/.${__target}/}: _SUBDIRUSE
.endfor
_SUBDIRUSE: .USE
- @OK=""; sub=${.TARGET:R}; \
+ @OK=""; sub=${.TARGET:S/^_//:R}; \
for dud in $$DUDS; do \
if [ $${dud} = $$sub ]; then \
OK="false"; \
${ECHO_MSG} "===> ${DIRPRFX}$$sub skipped"; \
fi; \
done; \
- if test -d ${.CURDIR}/${.TARGET:R}.${MACHINE_ARCH}; then \
+ if test -d ${.CURDIR}/$${sub}.${MACHINE_ARCH}; then \
edir=$${sub}.${MACHINE_ARCH}; \
elif test -d ${.CURDIR}/$${sub}; then \
edir=$${sub}; \
@@ -135,7 +135,7 @@ _SUBDIRUSE: .USE
DIRPRFX=${DIRPRFX}$$edir/; \
fi
-.for _subdir in ${SUBDIR}
+.for _subdir in ${SUBDIR:S/^/_/}
${_subdir}:: ${_subdir:S/$/.all/}
.endfor
@@ -150,14 +150,14 @@ afterinstall:
.endif
install: afterinstall
afterinstall: realinstall
-realinstall: beforeinstall ${SUBDIR:S/$/.realinstall/}
+realinstall: beforeinstall ${SUBDIR:S/^/_/:S/$/.realinstall/}
.endif
IGNOREDIR= CVS Mk Templates Tools distfiles packages pkg
.if !target(checksubdirs)
.if defined(PORTSTOP)
-checksubdirs: checksubdir ${SUBDIR:S/$/.checksubdirs/}
+checksubdirs: checksubdir ${SUBDIR:S/^/_/:S/$/.checksubdirs/}
.else
checksubdirs: checksubdir
.endif
@@ -187,7 +187,7 @@ checksubdir:
.endif
.if !target(readmes)
-readmes: readme ${SUBDIR:S/$/.readmes/}
+readmes: readme ${SUBDIR:S/^/_/:S/$/.readmes/}
.endif
.if !target(readme)