aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-22 05:26:01 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-22 05:26:01 +0000
commit78266a3a1f4f7cc194f33126b26d3e38d8ba0329 (patch)
treec44c1738dacfe47fe19672b3ac8604c02f1eccd2 /Mk/bsd.python.mk
parenta3897566f8e40672d5ad233d3d5659154955a09b (diff)
downloadports-78266a3a1f4f7cc194f33126b26d3e38d8ba0329.tar.gz
ports-78266a3a1f4f7cc194f33126b26d3e38d8ba0329.zip
Notes
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index d584cb789b81..69d19c5fd851 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -99,7 +99,8 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYNUMERIC - Dependency line for the numeric extension. Py-Numeric-17
# is the last release that works with Python versions older
# than 1.6.
-# PYNUMPY - Dependency line for the new numeric extension.# py-numpy, Py-Numeric is deprecated.
+# PYNUMPY - Dependency line for the new numeric extension.
+# py-numpy, Py-Numeric is deprecated.
#
# PYXML - Dependency line for the XML extension. As of Python-2.0,
# this extension is in the base distribution.
@@ -113,6 +114,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYHASHLIB - Dependency line for the hashlib package. As of Python-2.5,
# this module is in the base distribution.
#
+# PYWSGIREF - Dependency line for the wsgiref package. As of Python-2.5,
+# this module is in the base distribution.
+#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -450,6 +454,12 @@ PYHASHLIB= ${PYTHON_SITELIBDIR}/hashlib.py:${PORTSDIR}/security/py-hashlib
PYHASHLIB= ${PYTHON_LIBDIR}/hashlib.py:${PYTHON_PORTSDIR}
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
+PYWSGIREF= ${PYTHON_SITELIBDIR}/wsgiref/__init__.py:${PORTSDIR}/www/py-wsgiref
+.else
+PYWSGIREF= ${PYTHON_LIBDIR}/wsgiref/__init__.py:${PYTHON_PORTSIDR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO