aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.ruby.mk
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-14 14:36:13 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-14 14:36:13 +0000
commit47e904ae1e0dfc1abf326bc16e288bdfc2e5b694 (patch)
tree2381c9e3fc179167f80b08bb612be1951bcc7d4d /Mk/bsd.ruby.mk
parent6c77933ee7fd1ed5d339defa771d4ccf104e7c56 (diff)
downloadports-47e904ae1e0dfc1abf326bc16e288bdfc2e5b694.tar.gz
ports-47e904ae1e0dfc1abf326bc16e288bdfc2e5b694.zip
Notes
Diffstat (limited to 'Mk/bsd.ruby.mk')
-rw-r--r--Mk/bsd.ruby.mk8
1 files changed, 0 insertions, 8 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 4a79e040b95e..8007cab44cdb 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -46,9 +46,6 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# (default: setup.rb).
# USE_RUBY_RDTOOL - Says that the port uses rdtool to generate documents.
# USE_RUBY_RDOC - Says that the port uses rdoc to generate documents.
-# USE_RUBY_FEATURES - Says that the port requires some of the following
-# features for building and/or running (default: none):
-# iconv
# RUBY_REQUIRE - Set to a Ruby expression to evaluate before building
# the port. The constant "Ruby" is set to the integer
# version number of ruby, and the result of the
@@ -110,13 +107,11 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# RUBY_PORT - Port path of ruby without PORTSDIR.
# RUBY_RDTOOL_PORT - Port path of rdtool without PORTSDIR.
# RUBY_RDOC_PORT - Port path of rdoc without PORTSDIR.
-# RUBY_ICONV_PORT - Port path of ruby-iconv without PORTSDIR.
#
# DEPEND_LIBRUBY - LIB_DEPENDS entry for libruby.
# DEPEND_RUBY - BUILD_DEPENDS/RUN_DEPENDS entry for ruby.
# DEPEND_RUBY_RDTOOL - BUILD_DEPENDS entry for rdtool.
# DEPEND_RUBY_RDOC - BUILD_DEPENDS entry for rdoc.
-# DEPEND_RUBY_ICONV - BUILD_DEPENDS/RUN_DEPENDS entry for ruby-iconv.
#
# RUBY_LIBDIR - Installation path for architecture independent
# libraries.
@@ -294,14 +289,11 @@ RUBY_RDOC?= ${LOCALBASE}/bin/rdoc${RUBY_VER:S/.//}
RUBY_BASE_PORT?= lang/ruby${RUBY_VER:S/.//}
RUBY_PORT?= ${RUBY_BASE_PORT}
RUBY_RDTOOL_PORT?= textproc/ruby-rdtool
-RUBY_RDOC_PORT?= textproc/ruby-rdoc
-RUBY_ICONV_PORT?= converters/ruby-iconv
# Depends
DEPEND_LIBRUBY?= lib${RUBY_NAME}.so.${RUBY_SHLIBVER}:${PORTSDIR}/${RUBY_PORT}
DEPEND_RUBY?= ${RUBY}:${PORTSDIR}/${RUBY_PORT}
DEPEND_RUBY_RDTOOL?= ${RUBY_RD2}:${PORTSDIR}/${RUBY_RDTOOL_PORT}
-DEPEND_RUBY_ICONV= ${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/${RUBY_ICONV_PORT}
# Directories
RUBY_LIBDIR?= ${_RUBY_SYSLIBDIR}/ruby/${RUBY_VER}