aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.sanity.mk
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2015-01-07 17:22:07 +0000
committerMarcus von Appen <mva@FreeBSD.org>2015-01-07 17:22:07 +0000
commitbeb88abfedf552672e9bd92b91509ddfc6099dca (patch)
tree747cade4690b4fe5b456faf85b807d447f4e4846 /Mk/bsd.sanity.mk
parentc22ef12c7ebbf711551181fd3676b79223b1f392 (diff)
downloadports-beb88abfedf552672e9bd92b91509ddfc6099dca.tar.gz
ports-beb88abfedf552672e9bd92b91509ddfc6099dca.zip
- Remove support for deprecated python bits from the ports
framework. The following knobs are not supported anymore: USE_PYTHON=<yes|version+-|-version|version-version> USE_PYTHON_BUILD USE_PYTHON_RUN USE_PYDISTUTILS PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO PYTHON_CONCURRENT_INSTALL USE_PYTHON_PREFIX PR: 196477 Differential Revision: https://reviews.freebsd.org/D1416 Exp-run: antoine Reviewed by: antoine Approved by: portmgr (antoine) With hat: python
Notes
Notes: svn path=/head/; revision=376473
Diffstat (limited to 'Mk/bsd.sanity.mk')
-rw-r--r--Mk/bsd.sanity.mk26
1 files changed, 9 insertions, 17 deletions
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 17a80a2599dc..cbf23fe9ab6b 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -101,10 +101,6 @@ DEV_WARNING+= "MAN${a} macros are deprecated when using stage directory"
DEV_WARNING+= "MLINKS macros are deprecated when using stage directory"
.endif
-.if defined(PYDISTUTILS_AUTOPLIST) && defined(PYTHON_PY3K_PLIST_HACK)
-DEV_WARNING+= "PYDISTUTILS_AUTOPLIST features Python 3.x support, PYTHON_PY3K_PLIST_HACK is not required"
-.endif
-
.if defined(_PREMKINCLUDED)
DEV_ERROR+= "you cannot include bsd.port[.pre].mk twice"
.endif
@@ -123,30 +119,26 @@ DEV_WARNING+= "LICENSE must not contain BSD, instead use BSD[234]CLAUSE"
DEV_ERROR+= "USE_PYDISTUTILS=easy_install is no longer supported, please use USE_PYDISTUTILS=yes"
.endif
-.if defined(USE_PYDISTUTILS) && defined(PYDISTUTILS_AUTOPLIST) && defined(PYDISTUTILS_PKGNAME)
-DEV_WARNING+= "PYDISTUTILS_PKGNAME has no effect for USE_PYDISTUTILS=yes and PYDISTUTILS_AUTOPLIST=yes"
-.endif
-
.if defined(USE_PYTHON) && (${USE_PYTHON} == "yes" || ${USE_PYTHON:C/[-0-9.+]*//} == "")
_PYTHON_VAL := ${USE_PYTHON}
.if ${_PYTHON_VAL} != "yes"
-DEV_WARNING+= "USE_PYTHON=${_PYTHON_VAL} is deprecated, please use USES=python:${_PYTHON_VAL}"
+DEV_ERROR+= "USE_PYTHON=${_PYTHON_VAL} is no longer supported, please use USES=python:${_PYTHON_VAL}"
.else
-DEV_WARNING+= "USE_PYTHON=yes is deprecated, please use USES=python"
+DEV_ERROR+= "USE_PYTHON=yes is no longer supported, please use USES=python"
.endif
.endif
.if defined(USE_PYTHON_RUN)
.if ${USE_PYTHON_RUN} != "yes"
-DEV_WARNING+= "USE_PYTHON_RUN is deprecated, please use USES=python:${USE_PYTHON_RUN},run"
+DEV_ERROR+= "USE_PYTHON_RUN is no longer supported, please use USES=python:${USE_PYTHON_RUN},run"
.else
-DEV_WARNING+= "USE_PYTHON_RUN is deprecated, please use USES=python:run"
+DEV_ERROR+= "USE_PYTHON_RUN is no longer supported, please use USES=python:run"
.endif
.endif
.if defined(USE_PYTHON_BUILD)
.if ${USE_PYTHON_BUILD} != "yes"
-DEV_WARNING+= "USE_PYTHON_BUILD is deprecated, please use USES=python:${USE_PYTHON_BUILD},build"
+DEV_ERROR+= "USE_PYTHON_BUILD is no longer supported, please use USES=python:${USE_PYTHON_BUILD},build"
.else
-DEV_WARNING+= "USE_PYTHON_BUILD is deprecated, please use USES=python:build"
+DEV_ERROR+= "USE_PYTHON_BUILD is no longer supported, please use USES=python:build"
.endif
.endif
@@ -162,10 +154,10 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_READLINE USE_ICONV PERL_CONFIGURE PERL_MODBUILD \
USE_PERL5_BUILD USE_PERL5_RUN USE_DISPLAY USE_FUSE \
USE_GETTEXT USE_GMAKE USE_SCONS USE_DRUPAL NO_INSTALL_MANPAGES \
- INSTALLS_SHLIB
-SANITY_DEPRECATED= USE_XZ USE_BZIP2 USE_PYDISTUTILS PYTHON_CONCURRENT_INSTALL \
+ INSTALLS_SHLIB USE_PYDISTUTILS PYTHON_CONCURRENT_INSTALL \
PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO \
- USE_PYTHON_PREFIX PYTHON_PKGNAMESUFFIX
+ USE_PYTHON_PREFIX
+SANITY_DEPRECATED= USE_XZ USE_BZIP2 PYTHON_PKGNAMESUFFIX
USE_OPENAL_ALT= USES=openal
USE_FAM_ALT= USES=fam