aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.ssp.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-08-16 21:18:49 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-08-16 21:18:49 +0000
commitc40136b051898d49afcda53c10599fe5e8e0a6b9 (patch)
treea3c02b2365b587c93da96ede668a60112238640c /Mk/bsd.ssp.mk
parent5612d7cdef47afad431c896b0a05ee7ccffe9270 (diff)
downloadports-c40136b051898d49afcda53c10599fe5e8e0a6b9.tar.gz
ports-c40136b051898d49afcda53c10599fe5e8e0a6b9.zip
No need to expand CFLAGS/LDFLAGS here.
With hat: portmgr
Notes
Notes: svn path=/head/; revision=365137
Diffstat (limited to 'Mk/bsd.ssp.mk')
-rw-r--r--Mk/bsd.ssp.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.ssp.mk b/Mk/bsd.ssp.mk
index adb6a3bfcf0d..a62f898a82f7 100644
--- a/Mk/bsd.ssp.mk
+++ b/Mk/bsd.ssp.mk
@@ -20,11 +20,11 @@ SSP_NEED_NONSHARED= yes
(${ARCH} == i386 || ${ARCH} == amd64)
# Overridable as a user may want to use -fstack-protector-all
SSP_CFLAGS?= -fstack-protector
-CFLAGS:= ${CFLAGS} ${SSP_CFLAGS}
-LDFLAGS:= ${LDFLAGS} -fstack-protector
+CFLAGS+= ${SSP_CFLAGS}
+LDFLAGS+= -fstack-protector
# -lssp_nonshared is needed on i386 where /usr/lib/libc.so is not an ldscript
# This is currently unused XXX
. if defined(SSP_NEED_NONSHARED)
-LDFLAGS:= ${LDFLAGS} -lssp_nonshared
+LDFLAGS+= -lssp_nonshared
. endif
.endif