aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.tex.mk
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-07-25 16:13:54 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-07-25 16:13:54 +0000
commitcc4a6b7ab5cecce7a0592b0143cad3a15f695c96 (patch)
tree12a33b2163cd99b29ccbb3a50ef1121c1586a1ce /Mk/bsd.tex.mk
parent1a3e636c6019ce4406ff5f86e0ab8a9cc9c93e28 (diff)
downloadports-cc4a6b7ab5cecce7a0592b0143cad3a15f695c96.tar.gz
ports-cc4a6b7ab5cecce7a0592b0143cad3a15f695c96.zip
- Fix a bug which prevented both a package version number and arguments
at the same time in USE_TEX from working. - Enforce to use a package version number for dependency on base and texmf.
Notes
Notes: svn path=/head/; revision=392891
Diffstat (limited to 'Mk/bsd.tex.mk')
-rw-r--r--Mk/bsd.tex.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/Mk/bsd.tex.mk b/Mk/bsd.tex.mk
index 5867e1aa6a04..9041afdd3746 100644
--- a/Mk/bsd.tex.mk
+++ b/Mk/bsd.tex.mk
@@ -157,7 +157,16 @@ USE_TEX:= ${USE_TEX:tu:NFULL} ${_USE_TEX_FULLLIST:tu}
.for _UU in ${USE_TEX:tu}
_U:= ${_UU} # ugly but necessary in for loop
_VOP:=
-. if !empty(_U:tu:MKPATHSEA) || !empty(_U:tu:MPTEXENC) || !empty(_U:tu:MTEXLUA) || !empty(_U:tu:MTEXLUAJIT)
+. if !empty(_U:tu:C/[<>=][^\:]*//:C/\:.*$//:MTEXMF) && empty(_U:M*[<>=]*)
+_U:= ${_U}>=20150523
+. endif
+. if !empty(_U:tu:C/[<>=][^\:]*//:C/\:.*$//:MBASE) && empty(_U:M*[<>=]*)
+_U:= ${_U}>=20150521
+. endif
+. if !empty(_U:tu:C/[<>=][^\:]*//:C/\:.*$//:MKPATHSEA) || \
+ !empty(_U:tu:C/[<>=][^\:]*//:C/\:.*$//:MPTEXENC) || \
+ !empty(_U:tu:C/[<>=][^\:]*//:C/\:.*$//:MTEXLUA) || \
+ !empty(_U:tu:C/[<>=][^\:]*//:C/\:.*$//:MTEXLUAJIT)
_U:= ${_U}:lib
. endif
. if !empty(_U:M*[<>=]*)
@@ -166,8 +175,9 @@ _VOP:= ${_U:C/^[^<>=]*//:C/\:.*$//}
. if empty(_U:M*\:*)
_C:= BUILD RUN
. else
-_C:= ${_U:C/.*://:S/,/ /g}
+_C:= ${_U:C/.*://:S/,/ /g:C/[<>=][^\:]*//g}
. endif
+#. warning DEBUG: ${_U}: _VOP=${_VOP}, _C=${_C}
. for _CC in ${_C:tu}
_V:=${_UU:C/[<>=][^\:]*//:C/\:.*$//}
. if defined(_USE_TEX_${_V}_PORT)