aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.wx.mk
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 17:54:39 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 17:54:39 +0000
commit5b12368729dd4e75b4e6b9264178e6e4b10cc1e0 (patch)
tree75358ed36fe38220518d02a368d1a1bd2b1f5bf0 /Mk/bsd.wx.mk
parent79519c9dabf500dacc6c39e524698b579b26bd86 (diff)
downloadports-5b12368729dd4e75b4e6b9264178e6e4b10cc1e0.tar.gz
ports-5b12368729dd4e75b4e6b9264178e6e4b10cc1e0.zip
- Complete repocopy of x11-toolkits/py-wxPython28,
x11-toolkits/py-wxPython28-common and x11-toolkits/py-wxPython28-unicode, applying the corresponding patches. - Add PYDISTUTILS_NOEGGINFO to fix plist issues [1]. - Integrate with bsd.wx.mk: the noticeable difference is that ports using USE_WX=2.6+ and WX_COMPS=python will be built from now on with wxWidgets 2.8, which was previously restricted for these ports because of the lack of the "python" component for version 2.6 [1]. PR: ports/115349, ports/115350, ports/115351 Submitted by: Neal Nelson <neal@nelson.name> Reworked by: alepulver (myself) [1]
Notes
Notes: svn path=/head/; revision=200368
Diffstat (limited to 'Mk/bsd.wx.mk')
-rw-r--r--Mk/bsd.wx.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index ceb3c10e95dc..c88e3cda359c 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -34,9 +34,9 @@
# The available components are:
# wx - The wxWidgets library.
# contrib - The wxWidgets contributed libraries.
-# python - The wxWidgets API for Python (for 2.4-2.6).
-# mozilla - WxMozilla (for 2.4).
-# svg - WxSVG (for 2.6).
+# python - The wxWidgets API for Python.
+# mozilla - WxMozilla (only for 2.4).
+# svg - WxSVG (only for 2.6).
# The available dependency types are:
# build - Requires component for building.
# lib - Requires component for building and running.
@@ -178,6 +178,9 @@ _WX_LIB_wx_2.8= wx_base${_WX_UC}-2.8
_WX_PORT_contrib_2.8= x11-toolkits/wxgtk28${_WX_UCL}-contrib
_WX_LIB_contrib_2.8= wx_gtk2${_WX_UC}_fl-2.8
+_WX_PORT_python_2.8= x11-toolkits/py-wxPython28${_WX_UCL}
+_WX_FILE_python_2.8= ${PYTHON_SITELIBDIR}/wx-2.8-gtk2${_WX_PYSUFX}/wx/__init__.py
+
# Set _WX_SHVER_comp_ver to 0 and _WX_FILE_comp_ver for libs appropiately.
# Set _WX_DEPTYPE_comp_ver for "python" to "run", and others to "lib".