aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.wx.mk
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-10-19 02:21:14 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-10-19 02:21:14 +0000
commitd39f10a502f5b7f8a90db5e6b5020e9df4d8bf41 (patch)
tree26b1659226fc7a65173b54b8bef96d2f0a87b3ac /Mk/bsd.wx.mk
parent9efbb811bed7f41b43b47766db09be1ba47815c0 (diff)
downloadports-d39f10a502f5b7f8a90db5e6b5020e9df4d8bf41.tar.gz
ports-d39f10a502f5b7f8a90db5e6b5020e9df4d8bf41.zip
- Remove Unicode checks for FreeBSD < 5.x (unsupported).
PR: ports/116891 Submitted by: edwin
Notes
Notes: svn path=/head/; revision=201654
Diffstat (limited to 'Mk/bsd.wx.mk')
-rw-r--r--Mk/bsd.wx.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index c88e3cda359c..c2d799c8e63d 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -204,7 +204,7 @@ _WX_DEPTYPE_${comp}_${ver}= lib
# Check if the user/port wants Unicode.
#
-.if ${OSVERSION} >= 500000 && (!defined(WITHOUT_UNICODE) && \
+.if (!defined(WITHOUT_UNICODE) && \
(defined(WITH_UNICODE) || defined(WANT_UNICODE)))
_WX_UC_AVAILABLE= yes
.else
@@ -441,9 +441,7 @@ WX_UNICODE= yes
# Requested by the port (mandatory).
.if defined(WX_UNICODE)
-. if ${OSVERSION} < 500000
-IGNORE?= requires FreeBSD versions >= 5.X (because of Unicode)
-. elif empty(_WX_VER_UC)
+. if empty(_WX_VER_UC)
IGNORE?= selected a wxWidgets version which does not support Unicode: ${_WX_VER_MERGED}
. endif
.endif